331.20 doesn't show Googleearth photos

331.17 had this bug. and it still persists…older driver worked perfectly.
Gentoo, kernel-3.12.0 (generic) 32bit.

bug log attached.
nvidia-bug-report.log.gz (37.6 KB)

Sorry I started without options when creating nvidia-bug-reportlog.gz. Now I created one with “startx – -logverbose 6”.

GoogleEarth almost works; 3d objects are displayed, terrain are displayed. However somehow, only satellite photo isn’t displayed.
nvidia-bug-report.log.gz (57.6 KB)

Works for me: http://imgur.com/bQYlpXo



What’s the kernel number? I’m using 3.12.0. And what is the version number of GoogleEarth? Mine is Mine shows only buildings w/o some texture. :(

My whitehouse:

Get closer:

Again, what can’t you see? 3D models or something different?

i have same issue like maverick6664

the whitehouse turns to blackhouse

Drivers: 330.20
kernel: 3.12.0

I can confirm this problem. Sat imagery (terrain) goes black with nVidia driver 331.20.

As a workaround, you can disable “Compression” in GE Tools -> Options -> 3D View -> Texture colors.

(Unfortunately, disabling “Compression”, GE gets slower).

yes, i can confirm xralph say after clean GE cache

As reported by many users, this bug also affects the latest nVidia drivers for Windows and MacOSX.

xralph’s workaround works for me. Thank you. Since Windows and MacOSX are affected, is this a nVidia’s bug?

In my case, GE (with “compression” enabled) works perfectly with nVidia driver 325.15.

BTW, I’m using GE 6.x stable - 7.x is not available for RPM distros yet.


with work around still does not show photos 331.17 331.20 and 331.15 tears with video but google earth works any solutions?

hausoo, Please provide nvidia bug report and screenshots.