450.57 on Fedora 31 Can't Install libglvnd

On Fedora 31, Driver 450.57 generates an error when installing:

nvidia executing: ‘/bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh’…
Internal error:

Previous versions would install and warn about an incomplete libglvnd and overwrote it.

It is possible to install with --no-install-libglvnd and use the Fedora provided version.

Edit: Are the required libs installed?

$ rpm -qa libglvnd*


The Nvidia driver install fails without --no-install-libglvnd. Yes, Fedora does provide libglvnd, so everything works when the Nvidia driver is installed using --no-install-libglvnd. Previous versions of the Nvidia installer offered to replace it.

The check works fine on F33

[leigh@leigh NVIDIA-Linux-x86_64-450.57]$ /bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh
Found libglvnd libraries: libGLESv2.so.2 libGLESv1_CM.so.1 libOpenGL.so.0 libEGL.so.1 libGLX.so.0 libGL.so.1
Found non-libglvnd libraries:
Missing libraries:
libglvnd appears to be installed.
[leigh@leigh NVIDIA-Linux-x86_64-450.57]$ uname -r
[leigh@leigh NVIDIA-Linux-x86_64-450.57]

Is this a driver update?, try uninstalling the old one first.

I did try that, uninstalling 440.82 first, no change. 440.82 installed and updated the libglvnd files. Since than I’ve updated the computer to Fedora 32. 440.82 won’t install with that kernel. 450.57 installed on F32 if i used -no-install-libglvnd.

This computer has been updated with several versions of Fedora, and my installs are done remotely via ssh. Could those have anything to do with this issue?

In any case, the workaround allows it to install and it functions with no issues. I just wanted to post the info here and provide the workaround in case anyone else had a similar issue. A search did not turn up any other similar reports.

Same here, though on openSUSE Tumbleweed with kernel 5.8.

Fully up to date F32 Kernel 5.8.7, Nvidia driver 450.66 installs fine.

Doesn’t work for me. I still get an apparently clean install (I had noticed it no longer prompts to overwrite libglvnd), but when starting X, I get

Oh no! Something has gone wrong. (etc. on a white screen)

with or without -no-install-ligglvnd

Ah. Should have used – not - Will try again.

Still the same problem.
I don’t see how --no-install-libglvnd is supposed to help, as 440.100 will already have installed a copy.

I think you may have a different issue. If you are not getting:

nvidia executing: ‘/bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh’…
Internal error:

and it proceeds to install and you are then having an issue on startup with:

Oh no! Something has gone wrong. (etc. on a white screen)

You probably should start a new thread with your specific problem so it gets addressed, as this one appears to be solved.

OK. I’m not getting that.
I did start a thread on it days ago, but I get no replies. How do I get Nvidia to look at it?

Hi colinpauladams,
Could you please share nvidia bug report.
If i understood correctly, you are able to install driver successfully but getting trouble with starting X.

I made the report in X won't start with GTX 780Ti card and 450.66 driver