New laptop with M2000M running Fedora25: installing driver fails on libglvnd and dkms

Hi,

On my laptop with full HD screen, I run Fedora 25 with LXDE. What happens is that the screen resolution stays at 800x600. I know full HD is available, because at boot in textmode, the screen shows small print. When graphics (Xorg) is started, 800x600 mode starts and can’t be changed. xrandr also shows only this mode.
Since I find no way to attach the full install log from the driver, I copied it in full:

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Wed Dec 7 07:23:44 2016
installer version: 375.20

PATH: /sbin:/bin:/usr/sbin:/usr/bin

nvidia-installer command line:
./nvidia-installer

Using: nvidia-installer ncurses v6 user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
-> Tagging shared libraries with chcon -t textrel_shlib_t.
-> License accepted.
-> Installing NVIDIA driver version 375.20.
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
-> Installing both new and classic TLS OpenGL libraries.
-> Installing both new and classic TLS 32bit OpenGL libraries.
-> Install NVIDIA’s 32-bit compatibility libraries? (Answer: Yes)
-> Will install GLVND GLX client libraries.
-> Will install GLVND EGL client libraries.
-> Skipping GLX non-GLVND file: “libGL.so.375.20”
-> Skipping GLX non-GLVND file: “libGL.so.1”
-> Skipping GLX non-GLVND file: “libGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.375.20”
-> Skipping EGL non-GLVND file: “libEGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.1”
-> Skipping GLX non-GLVND file: “./32/libGL.so.375.20”
-> Skipping GLX non-GLVND file: “libGL.so.1”
-> Skipping GLX non-GLVND file: “libGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.1”
-> Skipping EGL non-GLVND file: “./32/libEGL.so.375.20”
-> Skipping EGL non-GLVND file: “libEGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.1”
Looking for install checker script at ./libglvnd_install_checker/check-libglvnd-install.sh
executing: ‘/bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh’…
Checking for libglvnd installation.
Checking libGLdispatch…
Checking libGLdispatch dispatch table
Checking call through libGLdispatch
All OK
libGLdispatch is OK
Checking for libGLX
libGLX is OK
Checking entrypoint library libOpenGL.so.0
Checking call through libGLdispatch
Checking call through library libOpenGL.so.0
All OK
Entrypoint library libOpenGL.so.0 is OK
Checking entrypoint library libGL.so.1
Checking call through libGLdispatch
Checking call through library libGL.so.1
glGetString was not called
-> An incomplete installation of libglvnd was found. Do you want to install a full copy of libglvnd? This will overwrite any existing libglvnd libraries. (Answer: Install and overwrite existing files)
Will install libglvnd libraries.
Will install libEGL vendor library config file to /usr/share/glvnd/egl_vendor.d
-> Searching for conflicting files:
-> done.
-> Installing ‘NVIDIA Accelerated Graphics Driver for Linux-x86_64’ (375.20):
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-glcore.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/xorg/modules/extensions/libglx.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-tls.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/tls/libnvidia-tls.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLX_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libOpenGL.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLESv1_CM.so.1’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLESv2.so.2’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLdispatch.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLX.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGL.so.1.0.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libEGL.so.1’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/xorg/modules/drivers/nvidia_drv.so’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/xorg/modules/libnvidia-wfb.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-gtk2.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-gtk3.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-cfg.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-ml.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/vdpau/libvdpau_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libcuda.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-opencl.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libOpenCL.so.1.0.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-fatbinaryloader.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-ptxjitcompiler.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvcuvid.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-encode.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-ifr.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-fbc.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-compiler.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-eglcore.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-glsi.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libEGL_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLESv2_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libGLESv1_CM_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib64/libnvidia-egl-wayland.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libcuda.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-fatbinaryloader.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-ptxjitcompiler.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-ml.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libOpenCL.so.1.0.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-compiler.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-opencl.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libOpenGL.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLdispatch.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLESv2.so.2’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLESv1_CM.so.1’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGL.so.1.0.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLX_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLX.so.0’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-glcore.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-tls.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/tls/libnvidia-tls.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/vdpau/libvdpau_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvcuvid.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-encode.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-eglcore.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-glsi.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libEGL.so.1’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libEGL_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLESv2_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libGLESv1_CM_nvidia.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-ifr.so.375.20’…
executing: ‘/bin/chcon -t textrel_shlib_t /usr/lib/libnvidia-fbc.so.375.20’…
-> The installer has encountered the following error during installation: ‘Cannot create symlink /usr/lib/libEGL.so (File exists)’. Would you like to continue installation anyway? (Answer: Continue installation)
executing: ‘/sbin/ldconfig’…
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
ERROR: Unable to load the ‘nvidia-drm’ kernel module.
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

I tried again, this time without DKMS and libglvnd. Although the driver did install this time, and using nvidia-configure which created xorg.conf (which still holds back the graphics when in /etc/X11) , I still am on 800x600 resolution and unable to change it. “NVIDIA X Server Settings” does start, but it says that the driver isn’t being used. So I’m still clueless.