Quadro K620 on Fedora 25 Unable to load the 'nvidia-drm'

Two issues in running the 375.39 installer on a fresh Fedora 25 installation (updated to 4.9.11-200): “An incomplete installation of libglvnd was found” (though the installer seems to work through this) and then a failure, at the end, to load nvidia-drm.

Not sure where to go next. I don’t absolutely need to be using Fedora, but I’d like to.

installer log attached.

nvidia-installer.log (8.58 KB)

I second this Issue, same kernel, fedora 25, GeForce 640, 375.39 installer – unable to load nvidia-drm at end of install … rpmfusion nvidia update as of today breaks the setup as well … Secure boot is disabled btw

I don’t think this is kernel specific, but rather related to the this bug https://bugzilla.redhat.com/show_bug.cgi?id=1413579#c54

I get the same error on kernel 4.9.10-200 and on 4.9.11-200 - and it happened when did a dnf update this afternoon including the files described in this bug. Also, this seem version unspecific. I were running 378.09 just fine before the update and broke both kernel versions. Tried to update to 378.13 same issue. Running with GTX1050 (probably doesn’t matter what card you run).

Same deal here - Fedora updates last night left me with a black screen and trying to re-install the NVIDIA drivers gives me the “incomplete installation of libglvnd” warning and the “unable to load the ‘nvidia-drm’ kernel module” error. The packages from RPM Fusion and Negativo17 install without displaying any errors but still leave me with a black screen.

I don’t have secure boot enabled, either.

Good to know I’m not alone.

I’ll note that I also tried the RPM Fusion approach returned no errors but also failed to work.

This might be the culprit: https://bodhi.fedoraproject.org/updates/FEDORA-2017-31d4ea5eb1

Thanks, Quppa. It looks like you’re right.

Now what?

There’s another discussion about this issue here: http://forums.fedoraforum.org/showthread.php?p=1782356

I’ll try the solution pugwash posted when I get a chance.

Currently using fedora 25 and was faced with the same problem when I updated (GTX950).
I decided to set SELinux to permissive instead of enforcing by doing the following:

1 - open /etc/selinux/config using your favourite text editor
2 - change SELINUX=enforcing to SELINUX=permissive
3 - reinstall the driver(Driver from the NVIDIA site, not RPM fusion or negativo17, so unsure if its the same issue regarding those drivers)

After doing this the install worked perfectly and I’m able to do this now :D

For more information on the effects of the changes to SELinux:

I hope this helps
Cheers

Yes, this is truly a SElinux problem :) permissive mode solves the problem :) thx!

Thanks, y’all. I’m going to mark this as answered, though I won’t have a chance to try it for a couple days.

A final note: driver install is back to working normally with the 4.9.12-200 kernel update.

There’s a new patch for selinux-policy that should solve these issues: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e06f91350b

It’s been pushed to stable.

the selinux-policy fixed this for me as well.