Unable to load the 'nvidia-drm' kernel module. Fedora 25 kernel 4.9.11

Hi all!

After a dnf update the 375.26 driver stops running X.
I try to uninstall and reinstall but does not work.

During instalation I’m having this message: ERROR: Unable to load the ‘nvidia-drm’ kernel module.
I try with the latest driver (375.39) for my GTX 960 but same result.

$ uname -a
Linux hostname 4.9.11-200.fc25.x86_64 #1 SMP Mon Feb 20 18:11:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)

How can I run again graphical mode?
nvidia-bug-report.log.gz (65.8 KB)
nvidia-installer.log (7.83 KB)

This is because the latest SELinux update introduced a policy that blocks the ‘nvidia-drm’ kernel module to be loaded. Would you try disable selinux or set it to permissive, and install the driver again?

I had similar issue and I tried first to set SElinux policy to permissive, but unfortunately module will load only if SElinux is fully disabled.

Hi xwang,

I solve the problem disabling selinux and reinstalling the latest driver.
With graphical target running I try to enable again SELinux and reboot, but the system does not boot until I connect to ssh and set “setenforce 0”

Any solution to get running both SELinux and NVIDIA driver on Fedora 25 with kernel 4.9.11?


sudo dnf downgrade selinux-policy\*

That helped, thanks

Thanks for the hints, disabling selinux did it. Better trick, since it fails to boot: add “selinux=0” to the parameters of the GRUB menu.

Would be great if a future driver update was able to workaround this? I use Fedora, but stick to the NVidia installer to manually re-install it as needed.

If working around the selinux policy isn’t possibly, maybe the installer could report a better error message? That would be very helpful, as fixing it was trivial after I found this information on this thread, but I was quite lost before.