ERROR: Unable to load the ‘nvidia-drm’ kernel module on Fedora 35, Quadro P520

I am trying to install nVidia drivers on my Fedora 35 laptop. The install fails with the error message:

ERROR: Unable to load the ‘nvidia-drm’ kernel module

I have tried:

  • disabling SE linux, setting SE linux to permissive mode, and downgrading the SE linux policy (suggestions from older forums)
  • using both the production (470.94) and “new feature” (495.46) versions of the driver
  • manually loading using “modprobe nvidia” (This was suggested in the nVidia README). This results in the error: modprobe: ERROR: could not insert 'nvidia': Key was rejected by service

The last few lines of the installer log contains:

-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (495.46):
   executing: '/usr/sbin/ldconfig'...
   executing: '/usr/bin/systemctl daemon-reload'...
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
ERROR: Unable to load the 'nvidia-drm' kernel module.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.

I have attached the full log file from [nvidia-bug-report.log.gz|attachment](upload://k6uWIwNff5n0YPqEsdgvRTA4Flk.gz) (87.9 KB)

Please try disabling secure boot in bios.
Furthermore, better install the driver from repo, not runfile installer.

Disabling secure boot solved the problem.

Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.