4K UHD TV Connecting at 30 Hz via HDMI

My new 4K SUHD TV (Samsung UN49KS8000FXZA) is only connecting at 30Hz; I can’t seem to get it to connect at 60Hz. My video card is GeForce GT 730 and I’m running Nvidia driver 364.19 on Ubuntu 14.04.4. I’m using it to watch broadcast TV only (no gaming or Blueray) so if I can downgrade the connection resolution to 1080i at 60Hz that would be fine. Is there a driver setting or modeline setting I need to use to get 60Hz?

Are you using HDMI 2.0?, if not 30Hz is the max for 4k.
Looking at your card spec your out of luck

* Maximum Digital Resolution - 3840x2160 at 30Hz or 4096x2160 at 24Hz supported over HDMI.3840x2160 at 60Hz supported over DisplayPort

Well that’s a bummer. Is there anyway, say via Nvidia driver setting or modeline setting, to downgrade the resolution to 1080i in order to increase the refresh rate? I’m using the card strictly for 1080i/720p broadcast TV so I don’t need 4K resolution.

If I can’t downgrade the resolution with this card do you have a recommendation for a card which will get me 60Hz on HDMI? My TV doesn’t seem to support DisplayPort. Thanks.

Any thoughts on how I can downgrade the resolution of the interface to 1080i so I can increase the refresh rate to 60Hz? I don’t need 4K resolution but do need 60Hz refresh. Thanks.

You can set the mode with xrandr: https://wiki.archlinux.org/index.php/xrandr

You can also change it with nvidia-settings in the X Server Display Configuration tab. It will be a 1080p mode, not 1080i. Your PC can do the deinterlacing.

In terms of getting 4k@60 Hz, you can get a DP to HDMI 2.0 adapter such as the Club3D CAC-1070. As of a few months ago, this was the only adapter that actually supported HDMI 2.0. I don’t know if that’s changed.