Problem with 4K@60Hz with NVIDIA-Linux-x86_64-375.39

This problem still exists with NVIDIA-Linux-x86_64-375.39 + kernel_4.10.patch
Hardware: NVIDIA Quatro K620, Samsung UE43KS7505 SUHD TV, Club 3D CAC-1070 (DP to HDMI)
Kernel 4.10.1

SO, in the windows I can use 3840x2160@60p with 4:4:4, but in linux I can reach only 3840x2160@30p RGB and if I enable “UHD Color”, result is black screen and TV says that “Mode not supported, 720x480 60i”

First boot:
UHD colors enabled from computer start, here is Xorg.0.log (with Option “ModeDebug”) https://drive.google.com/open?id=0B_nQziZUPvaucDNWc3dtelZaeEk
Screen goes black and TV is reporting not supported mode. If I press Ctrl-Alt-F1, screen stays black.

Second boot:
UHD colors disabled from computer start and Xorg starts to 3840x2160@30p mode. Then I change (at TV) UHD colors enabled and video card change it’s mode. Result is black screen and TV is reporting not supported mode. I press Ctrl-Alt-F1, screen STAYS black, but TV reports that mode is now 1920x1080@60p
Here is Xorg.0.log (with Option “ModeDebug”): https://drive.google.com/open?id=0B_nQziZUPvauVmdzMGd6VEp2bzA

Here is nvidia-bug-report.log.gz https://drive.google.com/file/d/0B_nQziZUPvauVVM1anNQbnhBRVk/view?usp=sharing (it was too big to attach here directly; 185,5KB)

That console blackness is strange. If I boot my computer, grub starts with 1920x1080 resolution what I have defined in grub.conf, but then system loads nvidia modules and result is black screen on that 1920x1080@60i… Result is same even I use nouveau driver. If I don’t enable UHD colors, I have no problem to use 3840x2160@30p mode in console.

Is there something information missing, what I could provide? To help solving this issue.
If this TV edid information is problem source, why then windows drivers don’t have any problem with it?

Is there tool what I could use to “edit” that edid.bin file? And then use it on xorg.conf…

I’m currently testing NVIDIA-Linux-x86_64-381.09, but problem still exists.
It looks like that nobody have any clue what is wrong or… Nobody at NVIDIA cares, because (as I said) this combination works with windows 10, what I don’t want to use.

Can you test with latest 375.66 and 381.22 drivers? Are you using Active or Passive dongle/adapter? Do you have DP-HDMI cable to test with? Please make sire to blaklist Nouveau driver with replace kernel parameters : vga=0 rdblacklist=nouveau nouveau.modeset=0.

Do you have any other TV/Monitor where same issue?

I tested with 381.22 drivers and result was same. Black screen and TV says that mode 720x480 60i is not supported.
Yes, I have active adapter between graphic card and TV. As I wrote in opening message. http://www.club-3d.com/index.php/products/reader.en/product/displayport-12-to-hdmi-20-uhd-active-adapter.html what works fine with windows.
Nouveau driver is blacklisted and I added those parameters to grub.cfg

No, I don’t have any other 4K monitor or TV at my disposal. Lower resolutions with 60Hz refresh rate works fine.
nvidia-bug-report.log.gz (160 KB)

At windows where this combination works, driver says that it is using:

3840   2160
0      0       Border
176    8       Front
88     10      Switch
296    72      Back
+      +       Polarity

Can I “build” modeline from those values? If that would work.

Hi JJussi, Please share the output of xrandr and xrandr --verbose when issue hit.

Hi!
Here is asked information.

xrandr.UHD.log - situation when problem exists and screen is black - mode not supported
xrand.noUHD.log - situation when refresh rate is 30Hz

xrandr.noUHD.no-verbose.log (987 Bytes)
xrandr.noUHD.log (11.2 KB)
xrandr.UHD.log (11.2 KB)
xrandr.UHD.no-verbose.log (987 Bytes)

So as per latest xrandr log looks 4k resolution is applied when UHD enabled but screen showing blank

3840x2160 60.00*+ 59.94 50.00 29.97 25.00 23.98

Do you have any other passive DP to HDMI dongle to test? Also any older drivers from http://download.nvidia.com/XFree86/Linux-x86_64/ help to resolve this issue?

>>in the windows I can use 3840x2160@60p with 4:4:4, but in linux I can reach only 3840x2160@30p RGB
So on windows without enabling UHD colors are you getting 3840x2160@60p with 4:4:4 ?

@JJussi: about modeline:
UHD on, the xserver tells it’s using

3840x2160 (0x43a) 594.000MHz +HSync +VSync *current +preferred
        h: width  3840 start 4016 end 4104 total 4400 skew    0 clock 135.00KHz
        v: height 2160 start 2168 end 2178 total 2250           clock  60.00Hz

Which is the same as the values you got from Windows.
width=3840+border=3840
start=width+front=4016
end=start+switch=4104
total=end+back=4400
same for vertical.

>> Do you have any other passive DP to HDMI dongle to test?

No, I don’t have… And it should not matter, because it’s external and it’s working in windows

>> Also any older drivers from http://download.nvidia.com/XFree86/Linux-x86_64/ help to resolve this issue?

I have tried 304.135 version (ubuntu repository), but no luck

>> So on windows without enabling UHD colors are you getting 3840x2160@60p with 4:4:4 ?

No, In windows UHD is enabled and I get 3840x2160@60p with 4:4:4 This TV accepts only 60Hz when UHD is enabled. When it’s disabled, it’s 30Hz with RGB

So, you can understand that, how frustrating is that, that this card+adapter+TV works perfectly in windows 10, but in linux I get black screen and complains that “Mode not supported, 720x480 60i”

Especially (as @generix wrote) if linux is using same “modeline” than what windows reports.

JJussi, I think it’s not that easy as it’s an active adapter, even capable of color conversion etc. Quite a lot of people having problems with it as well on Windows depending on gpu/driver/-version. You can try to get a newer firmware for it at support@club-3d.com or ask at their forum though Linux is not in their list of supported operating systems.
Edit: just a thought, since it’s active, it might be displaying an error message so it’s switching to 720x480@60i (ntsc-resolution) which is unfortunately not supported by your TV. Had the same thing once with an A/V-Receiver.

Hi all, We don’t have exact Samsung UE43KS7505 SUHD TV and Club 3D CAC-1070 (DP to HDMI) dongle. May be we can try repro with EDID of TV. Does the exact same issue repro on any other configuration of TV and dongle?

I got next answer from club-3d support:

>> Since the adapter does not have driver software it will not show any error message.

I also got link to newest firmware. I will test that tomorrow, when I can reboot this machine with windows.

>> Does the exact same issue repro on any other configuration of TV and dongle?

What I have tested (with other resolutions), no. All other native (lower) resolutions supports 60Hz. Only 3840x2160 and 4096x2160 have black screen on 60Hz.

Maybe also update the firmware of your TV. New firware release on 2017-04-27.

I managed (already) test this newest firmware… No change. Here is few screen shots from “windows size”.

My TV says that it have newest firmware already.

During visit on windows land, I saved EDID to disk. It is in txt format. How I can convert it to bin format, so I can check (to be sure) that it is same than what is extracted here at linux land. (it should be…)

Samsung_EDID.txt (768 Bytes)
edid.zip (422 Bytes)

I have filed Bug 200312705 to track this issue. We don’t have exact TV but we’ll see of provided EDID can help to reproduce this issue.

I got next message from Club-3D firmware developers, when I asked "in which situation adapter will output 720x480@60i:

[i]The adapter cannot change the resolution and or frequency it gets offered by host system graphcis. It has a Do receiver and HDMI Converter inside to convert the DP signal into HDMI

But cannot change it.

When the screen states it is getting for instance 720x480 at 60Hz it most probably means it is getting a signal it does not recognize or cannot display as a result of which it will generate some sort of “error message”. Most TV’s are not very advanced with regards to the Error Messaging…

Please try this:

Set output signal to 1920x1080p 60Hz 4:4:4 with Timing Standard to CVT-RB (Redecued Blanking). Reboot system.

Now set output signal to 4k 60Hz 4:4:4 with Timing Standard to CVT-RB (Redecued Blanking).

[/i]

So, how I (in linux) can set those 4:4:4 and CVT-RB. I tested just setting 1920x1080 to xorg.conf, reboot and setting then 4K@60Hz didn’t help.

Use
Option “ColorSpace” “YCbCr444”
or, if you have more than one display
Option “ColorSpace” “DFP-0: YCbCr444”
in your xorg.conf (either screen or device section, match DFP-0 with real connector)
calculate a modeline using
cvt -r 3840 2160 60
and set that in the screen section.