510/515 drivers throw Xid 62/16 with certain NVreg_RegistryDwords set

Hi,
I just picked up a 3090 Ti FE (upgrading from a 1080 Ti), and it worked fine on the latest 470.129 driver available in Ubuntu 20.04.

When I upgraded to 510.73 or 515.48, I noticed a single Xid event 62, then multiple 16’s shortly after launching X11 (with symptoms of huge slowdowns when rendering the desktop).

I traced this issue down to kernel options I had set for older drivers/cards to ensure DDC/i2c worked:
options nvidia NVreg_RegistryDwords=RMUseSwI2c=0x01;RMI2cSpeed=100

Removing these options seems to have fixed the driver errors/instability and things seem to be working fine now, just thought I’d report this issue in case anyone else has encountered it.

I am running a fully updated Ubuntu 20.04 with kernel 5.13.0-48 and the MATE desktop environment on a 144Hz monitor with the following X11 Screen config section set:
Option "MetaModes" "DP-4: 2560x1440_144 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}

No additional nvidia kernel options were set.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.
Another user has the same symptoms in a non-fixable manner.

Those DDC/I2C options have not been required for over a year now, as the issue has long been solved.