525.60.11 breaks composited desktop on X11 if laptop lid is closed

So I work with Lenovo Legion 5 15ARH05H with RTX 2060. It has 1080p panel, I use it with 1440p display connected via USB-C. It runs Arch Linux with KDE Plasma, hybrid graphics are enabled in UEFI.

After updating nvidia drivers to 525.60.11 if I close the lid (which switches output to external only) my desktop starts to be unusable, windows are laggy, text input is delayed massively.

Pausing compositing restores usability.

It feels like GPU is throttled, but frequency scaling seems to work according to nvidia-settings.
Tested kwin_x11 since I use KDE, also compiled compiz just for testing and it’s affected as well.
Now here’s the thing, it is working fine if laptop lid is open and both displays are being driven.

Downgrading to 520.56.06-2 from Arch Linux repository fixes this issue.
Here’s a log from working configuration (520.56.06), I will update my post to include logs from 525 series.
nvidia-bug-report.log.gz (1.1 MB)
Edit: Tested disabling internal screen from kde systemsettings, after it’s disabled same issue occurs.

Double posting as it won’t let me post two links per post.
Here are logs from 525.60.11 when lid is down. Session started via startx -- -logverbose 6
nvidia-bug-report-525.log.gz (1.2 MB)
Edit. Tried setting __GL_ExperimentalPerfStrategy=1 but that didn’t help.

Pretty sure that Slow when not unified.. again and Really slow output when screens not unified are related.

Upgraded to 525.78.01 and somehow it’s even worse now. Desktop freezes for a couple seconds when I close the lid, and then everything is as unresponsive as before.

Come on guys, updated to 525.85.05 and my desktop is still broken.
With some more experimenting I can say that it’s not just compositor that lags, every animated UI element is slow as hell.
Also, I noticed that with 525 Gsync no longer works, display is reported as incompatible and gsync is disabled.
It works with 520.56.06.

Status update: Arch released kernel 6.2 into stable. Nvidia 520.56.06 no longer builds:

==> dkms install --no-depmod nvidia/520.56.06 -k 6.2.1-arch1-1 Error! Bad return status for module build on kernel: 6.2.1-arch1-1 (x86_64)

Can I at least have anyone from Nvidia confirm whether there is a problem? Was it a mistake buying hardware from Nvidia?

I will switch to linux-lts for the time being.
Attaching module build log, I’m guessing something has changed in the kernel.
make.log (24.7 KB)

I’m currently having the same issue with the 525 driver. Please let me know if there are any developments!

Status update: I saw an article on phoronix about new nvidia drivers, there were some promising things listed so I removed nvidia from my package manager blacklist.

I can report that 530.41.03 fixes all issues I had in this thread. No more absymal framerate while only external screen is active.
I had some issues with G-SYNC not being detected, reconnecting DP on monitor end made it work. Hopefully it’s just driver update glitch.
MSI MAG321QR is the screen affected, connected via USB-C to DP cable.

Anyways, 525.105.17 would probably work as well since the changelog lists:

Fixed an issue which could cause applications to run at 1 FPS when using an NVIDIA PRIME Display Offload sink as the only active display.

So in short: 530.41.03 Worksforme™, 525.105.17 may also work.
Time will tell, thanks to devs for fixing it, it’s a bummer that your company is not very transparent on issues you are tracking.

Not everything is fine, gsync doesn’t work properly when only external screen is running. I get tearing even though gsync is reportedly working, at least according to nvidia-settings.
Edit 2.
Tearing on external screen is intermittent, sometimes I get it, sometimes it’s not there.
Attaching logs from 530.41.03.
nvidia-bug-report.log.gz (1.7 MB)

That’s interesting. I’ve seen multiple accounts of people experiencing issues with the 530.41.03 and external monitors. After upgrading, I experienced severe input lag on my external monitor. I’d like to know if composited desktop also works fine, or maybe it’s only when only a single monitor is active?

That’s interesting indeed. Compositing works with both screens, there is some intermittent tearing on the external display when is was the only one active.
For the reference I run X11 Plasma session with Kwin as the compositor.
I tried some games after update and they run fine.

Your issue sounds like what I was expiriencing before, so that’s weird. I do remember having severe lag on a 4K screen last time I tried Gnome, but I just assumed that Mutter is the culprit because it was fine on Plasma.

Since my last post I had a working desktop with 530.41.03. There is a new issue of intermittent tearing while scrolling inside a browser, or moving windows around. Could be related to idle power fixes.