525.60.11 breaks composited desktop on X11 if laptop lid is closed

So I work with Lenovo Legion 5 15ARH05H with RTX 2060. It has 1080p panel, I use it with 1440p display connected via USB-C. It runs Arch Linux with KDE Plasma, hybrid graphics are enabled in UEFI.

After updating nvidia drivers to 525.60.11 if I close the lid (which switches output to external only) my desktop starts to be unusable, windows are laggy, text input is delayed massively.

Pausing compositing restores usability.

It feels like GPU is throttled, but frequency scaling seems to work according to nvidia-settings.
Tested kwin_x11 since I use KDE, also compiled compiz just for testing and it’s affected as well.
Now here’s the thing, it is working fine if laptop lid is open and both displays are being driven.

Downgrading to 520.56.06-2 from Arch Linux repository fixes this issue.
Here’s a log from working configuration (520.56.06), I will update my post to include logs from 525 series.
nvidia-bug-report.log.gz (1.1 MB)
Edit: Tested disabling internal screen from kde systemsettings, after it’s disabled same issue occurs.

Double posting as it won’t let me post two links per post.
Here are logs from 525.60.11 when lid is down. Session started via startx -- -logverbose 6
nvidia-bug-report-525.log.gz (1.2 MB)
Edit. Tried setting __GL_ExperimentalPerfStrategy=1 but that didn’t help.

Pretty sure that Slow when not unified.. again and Really slow output when screens not unified are related.

Upgraded to 525.78.01 and somehow it’s even worse now. Desktop freezes for a couple seconds when I close the lid, and then everything is as unresponsive as before.