525.60.11 drivers + Ubuntu 22.04 LTS - graphics freezing (audio + OS continues)

Hi there,

Just a quick heads up - the 525.60.11 driver seems quite unstable on my setup:

RTX 3090
Ubuntu 20.04.5 LTS
AMD Ryzen 5 3600
MSI X570-A-PRO (X570-A PRO | Motherboard | MSI Global).

No overclocking set. All Vulkan games now ‘graphically freeze’ seemingly at random (sometimes lasts 2 minutes, sometimes 10mins, sometimes up to an hour) with no way to recover other than to kill game process.

Manually reverting to v520 (new features) driver has fixed the issue.

Let me know if you need any further information (and instructions on how to generate the diags / logs).


Please run nvidia-bug-report.sh as root after the issue occured and attach the resulting nvidia-bug-report.log.gz file to your post.

ok thanks - will do at weekend (this is also my daily driver machine and im a busy bunny during the week) - regards

Hi there,

ok - so please see this video where i play Assassins Creed Valhalla on the v520 drivers, Ive just gone back to the v525 drivers and didnt get even to the “Main Menu” ([LGOD] Play ASSASSINS CREED VALHALLA on Ubuntu Linux 22.04 LTS - YouTube) - also tried Cyberpunk 2077 which also freezed just seconds into gameplay.

Attached is the nvidia-bug-report as requested.


and the file (the log.gz version keeps getting stuck on “Processing”, so im uploading the actual plain-text .log from the archive):

nvidia-bug-report.log (3.3 MB)

Same driver bug as this

top man - thanks

just one query: no evidence that has been ‘logged as a bug’ - do we need to actually do that or do you know thats in a dev queue somewhere?

thanks again!

I can confirm this for Assassins Creed Valhalla. The game just freezes, no error is logged to dmesg, so nvidia-bug-report.sh would probably not generate any interesting results. Limiting the game to 30 fps can work around it but it’s unreliable (usually, it still freezes within an hour or two). Anything above 30 fps almost immediately freezes, either right away or when you start moving around.

This seems to be driver bug: The game works just fine with the same Proton version on Steam Deck, freezing reports seemingly only come from people using NVIDIA 525 drivers but I didn’t try reverting back to older drivers.

The system does not hard freeze, I can alt+tab back to desktop and kill the game, and everything still works. Also, sound continues to play when the freeze happens (although, only ambient sounds).

Other Ubisoft games do not seem to be affected (I tried Fenyx Rising and Odyssey which probably use a similar graphics engine).

GPU: RTX 3060 12GB
Drivers: 525.60.13
Gentoo Linux

I’m not sure if I can confirm Cyberpunk because it just crashes last time I tried, but that may be related to using DLSS. It still works on Steam Deck.

I can confirm Xid logs in dmesg when PCI-E power management is enabled. But that freezes the whole desktop then, maybe even hard freezes the system. It’s not limited to games in that case. Disabling all PCI-E power management options in the BIOS successfully worked around that for me, and that’s a completely different issue to what we’re seeing with Valhalla.

Still the same issue with 525.78.01…