545 drivers have bad flickering and black screen issues when VRR is enabled

What display do you have? It might help Nvidia devs to know what specific hardware.

1 Like

You can repro with:

  • Arch Linuux
  • Nvidia 545
  • Samsung G95NC

and running

swaymsg output HDMI-A-1 scale 1.25 resolution 7680x2160@59.987Hz

This will cause flickering on 545 but not on 535.


swaymsg output HDMI-A-1 adaptive_sync on 

Fixes flickering on 545, but will cause black screen.

1 Like

Any update now that an employee has identified a way to recreate this issue?


1 Like

As a temporary workaround to alleviate the flashing (inspired by UrbenLegend’s video): Turn off “Allow G-SYNC/G-SYNC Compatible” in the Nvidia Settings app → X Screen 0 → OpenGL Settings and set your game to windowed mode. Depending on the game, you might be able to get away with maximizing the window and hiding the title bar, etc.

Looking forward to a fix for this.


It is not necessary to run games in windowed mode. Just toggling gsync off in the Nvidia settings is fine. However, I have noticed that the setting does not persist on reboot. It will show as disabled in Nvidia settings, but VRR will actually be active and the flicker bug will appear. You have to toggle it on and off to disable VRR again.

1 Like

That reboot bug with the Nvidia settings definitely got me, thanks for mentioning.


I was able to repro issue locally, team is currently debugging the issue.
Shall keep updated on the same.


Awesome! I am super glad the dev team was able to reproduce this. Hopefully we won’t have to wait until the next major release in order to get a fix. Giving up VRR sucks!

Thanks for keeping us updated @amrits


it’s absolutely unbearable, i’m using minecraft as an example here, but this happens in a majority of games like vtmb, talos principle, chiv2. https://i.imgur.com/vg43GaI.mp4 (im using a 170hz display)


@amrits Any updates on if a fix is coming for this soon?

Issue is still being investigated by the team for the effective fix so that there will be no adverse impact with the fix.
Really appreciate for being patient, will keep you updated.


Issue has been root caused and fix will be available in future release drivers.


Wonderful news! Thanks for the update!

It’s been root caused and fixed at least three times already. How many times are left until I can use wayland+nvidia?

@mithras.ftw This issue happens on X as well with my 4090. It’s not Wayland-specific.

Any eta for the new driver?

Yeii. Love nvidia. Just in case I have a 4090 and it happens sometimes. Am using Xorg, not Wayland.

Can confirm VRR is fixed with the 550 beta drivers! Out of order frame issue on Wayland also seems to be fixed (I know the full fix won’t be out until explicit sync is adopted across the display stack, but at least it seems to be smooth on my end and isn’t giving me a seizure).

1 Like

Is VRR working for you with multiple monitors? Even on 550 its borked for me the second i turn on a second monitor

Nope it still only kicks in if I have only 1 monitor active.