After update of Ubuntu 22.04 lost ability to use Quadro P4000

After an update to Ubuntu 22.04 I can no longer change resolutions. Utilities like nvidia-smi fail to detect the card. The drivers appear to install without issue, and I can use the Nouveau driver without issue. However, I don’t get any of the functionality that I need from my Quadro P4000. Prior to the update it was working without fail.

I get the classic error from nvidia-smi

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have tried purging the nvidia drivers, tried 525 instead of 535. I even went through the process of installing the CUDA drivers.

nvidia-bug-report.log.gz (126.8 KB)

Ok, I changed kernels back to a previous kernel and I have functionality with my graphics card.

My container using the card won’t load, probably a separate issue but I have nvidia-smi returning results as expected.

This is the kernel currently loaded and allowing the P4000 to work:

linux-image-5.19.0-50-generic/jammy-updates,jammy-security,now 5.19.0-50.50 amd64 [installed,automatic]

This is the kernel that was apparently giving me issues, and loading by default:

linux-image-6.1.0-1015-oem/jammy-updates,jammy-security,now 6.1.0-1015.15 amd64 [installed,automatic]

Switched back to the latest kernel and ran this:

sudo apt -y install linux-headers-$(uname -r)

Problem solved.