Driver installed, but kernel modules not loaded

Hi,

I’ve been struggling with getting the Nvidia drivers to work on my new machine (4 RTX2080Ti GPUs). I tried installing them in various ways on fresh installs of Ubuntu 18.04 (tried the ppa, the .run file and most recently through Lambda Labs’ Stack). Kernel is 4.18.0-15-generic.

Currently, what I have is:

$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Also, the correct driver seems to have been installed:

$ dpkg -l | grep nvidia
ii  libnvidia-cfg1-418:amd64                   418.56-0lambda0~18.04                        amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-418                       418.56-0lambda0~18.04                        all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-418:amd64                418.56-0lambda0~18.04                        amd64        NVIDIA libcompute package
ii  libnvidia-compute-418:i386                 418.56-0lambda0~18.04                        i386         NVIDIA libcompute package
ii  libnvidia-decode-418:amd64                 418.56-0lambda0~18.04                        amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-418:i386                  418.56-0lambda0~18.04                        i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-418:amd64                 418.56-0lambda0~18.04                        amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-418:i386                  418.56-0lambda0~18.04                        i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-418:amd64                   418.56-0lambda0~18.04                        amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-418:i386                    418.56-0lambda0~18.04                        i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-418:amd64                     418.56-0lambda0~18.04                        amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-418:i386                      418.56-0lambda0~18.04                        i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-418:amd64                   418.56-0lambda0~18.04                        amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-418:i386                    418.56-0lambda0~18.04                        i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-418                   418.56-0lambda0~18.04                        amd64        NVIDIA compute utilities
ii  nvidia-cuda-dev:amd64                      10.0.130-0lambda3                            amd64        CUDA development files
ii  nvidia-cuda-doc                            10.0.130-0lambda3                            all          CUDA toolkit documentation
ii  nvidia-cuda-gdb                            10.0.130-0lambda3                            amd64        CUDA Debugger
ii  nvidia-cuda-runtime-9.0:amd64              9.0.176.4-0lambda1                           amd64        CUDA runtime (version 9.0)
ii  nvidia-cuda-toolkit                        10.0.130-0lambda3                            amd64        CUDA development toolkit
ii  nvidia-dkms-418                            418.56-0lambda0~18.04                        amd64        NVIDIA DKMS package
ii  nvidia-driver-418                          418.56-0lambda0~18.04                        amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-418                   418.56-0lambda0~18.04                        amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-418                   418.56-0lambda0~18.04                        amd64        NVIDIA kernel source package
ii  nvidia-prime                               0.8.8.2                                      all          Tools to enable NVIDIA's Prime
ii  nvidia-profiler                            10.0.130-0lambda3                            amd64        NVIDIA CUDA profiler
ii  nvidia-settings                            418.56-0lambda1                              amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-418                           418.56-0lambda0~18.04                        amd64        NVIDIA driver support binaries
ii  xserver-xorg-video-nvidia-418              418.56-0lambda0~18.04                        amd64        NVIDIA binary Xorg driver

However,

$ lsmod | grep nvidia
$ modprobe nvidia
modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.18.0-15-generic

and nvidia-settings gives

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

Any help on this would be appreciated… Only writing here since I’ve basically tried everything out there to no avail.

Thanks!

Looks like you are missing one of these:

linux-headers(-generic), make or build-essential or all of them.

And you kernel module doesn’t get built.

Thanks for the quick response!
As far as I can tell, all three are installed on my system.

Then please upload your nvidia-bug-report

This ended up being an unrelated hardware problem.

Thanks!