After upgrading deepstream from 4 to 5, the video surface turned to red

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson Nano)
• DeepStream Version(5.0)
• JetPack Version (4.4 GA)
**• TensorRT Version(7.1)
**• QtGStreamer 1.0


I compared the plugin of nvvideoconvert between 4 and 5

It seems some changes.
The pipeline is very simple: uridecodebin -> nvvideoconvert -> videoconvert-> qtquick2videosink
I debugged and found that the allowed caps of qtquick2videosink are “I420” and “BGRx”, but the final used caps was I420. when I specified the “BGRx”, the pad link was ok, but the test app would crash.


Hope someone to help, Thanks

Hi thin.wu,

The DeepStream SDK 5.0 DP version can’t work well on JetPack 4.4 GA yet, we’re preparing the new release to support it. Please roll back to the JetPack 4.4 DP or wait for the next release.

Thanks

I also tried JetPack 4.4DP before, but it is still not working

Hi,
Please try

uridecodebin -> nvvideoconvert -> videoconvert-> xvimagesink

Probably the issue is specific to qtquick2videosink.