AGX Orin Recovery Boot

I am doing some custom kernel development with my AGX Orin (Jetpack 5.1/L4T 35.2.1) and inadvertently installed a bad kernel image. After failing to boot the kernel image, the system rebooted itself and is now attempting to do a Recovery Boot instead. From the UART log:

L4TLauncher: Attempting Recovery Boot

How do I prevent this from happening? I have a backup kernel already included in my extlinux.conf file, so ideally the system would return to the normal “Direct Boot” operation and let me select the alternate backup kernel, but instead it only ever tries to do the Recovery Boot, and I have no way to select any other option. Is there a configuration/dts file somewhere that I need to modify to disable this behavior?

Interestingly, I have a second Orin system, running the same Jetpack, that allows me the opportunity to enter the UEFI boot menu:

Jetson UEFI firmware (version 2.1-32413640 built on 2023-01-24T23:12:27+00:00)
ESC   to enter Setup.
F11   to enter Boot Manager Menu.
Enter to continue boot.

But on my system that is booting the Recovery Boot, I never get this option. Do I need to do something to enable this option?

Hi, can you boot properly if the backup kernel is the only system installed?
(At least boot into the console mode so you can modify extlinux.conf.)
Also try if this post helps.

Thanks for the reply. It looks like I am able to get to the UEFI boot manager by pressing ESC during the boot process, even though it doesn’t print that prompt. Unfortunately I still cannot get the system too boot my backup kernel. If I select the eMMC device, it tries to boot and immediately goes back to the Recovery Boot and does not give me the expected options from my extlinux.conf file. It just prints:

L4TLauncher: Attempting Recovery Boot

and not this like I would expect:

L4TLauncher: Attempting Direct Boot
L4T boot options
0: primary kernel
1: backup kernel
Press 0-1 to boot selection within 3.0 seconds.
Press any other key to boot default (Option: 0)

From the UEFI boot menu I also try to boot from file, but unfortunately my /boot/Image.backup file does not show up as an option for some reason?

Ideally what I would like is one of two solutions:

  • Disable the bootloader’s watchdog feature that is triggering the reboot into this Recovery state, so that the system never gets into this state.
  • Find a way to switch back to do the Direct Boot instead of the Recovery Boot once the system is in this state.


Please try below method and it will go back to direct Boot again.

Press ESC to enter UEFI Menu, then choose Device Manager → NVIDIA Configuration → L4T Configuration → OS chain A status → (The value is Unbootable if UEFI attemps recovery kernel) choose Normal → Save and exit, reboot, UEFI will try Direct Boot.


Thank you, that solved the issue! Is there anyway to stop the system from defaulting into the Recovery Boot state? Also, any idea why I am not seeing the prompt to enter UEFI setup? Luckily pressing ESC still opens the setup menu.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.