AGX Xavier on J5.0.2

Hi

I’ve modified the dts and used on our carrier board

After building the dts and complete flashing to the AGX, the dtb seems not apply

And the reason could be the /boot/extlinux/extlinux.conf has set the /boot/dtb/kernel_tegra194-p2888-0001-p2822-0000.dtb for default

So I copy the L4T/bootloader/kernel_tegra194-p2888-0001-p2822-0000.dtb on my host, and overwrite the /boot/dtb/kernel_tegra194-p2888-0001-p2822-0000.dtb on the target

But it still not work

Then I tried the tegra194-p2888-0001-p2822-0000.dtb under the bootloader to overwrite the /boot/dtb/kernel_tegra194-p2888-0001-p2822-0000.dtb on the target

it works

My question is what are these dtb files means?

Most of them are the same certified by the command “diff”

What’s the file in bootloader correspond to the dtb under /boot/dtb in target

How the tegra194-p2888-0001-p2822-0000.dtb appears under bootloader?

Why it is different from the kernel_tegra194-p2888-0001-p2822-0000.dtb?

I didn’t encounter this situation when I use AGX Xavier on J4.6.2

Sorry for my shallow knowledge

Please kindly reply me

You just need to add your new dtb to L4T/kernel/dtb. No need to care about the rest of dtb under either bootloader or rootfs.

The flash script will handle them (copy/overwrite).

Hi WayneWWW

After I copy to L4T/kernel/dtb and flash, the dtb should be apply.

But In fact not

So I try to clarify what’s different between each dtb and what is the dtb I build apply on target

After you copy your dtb to L4T/kernel/dtb, how did you flash your board?

Hi

I execute the command belowed
sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1

Hi

Maybe the reason could be I cloned the system.img from the target

The full progress what I did:

  1. Use sdkmanager to flash the default image
  2. I modified some contents and installed the software what I need
  3. Clone the system.img and mount the img.raw to L4T/temp
  4. Copy the L4T/temp/* to L4T/rootfs (before copy, I have cleared the rootfs)
  5. Modified the dts and kernel
  6. Copy Image and dtb to L4T/kernel after build
  7. Execute the apply_binaries.sh
  8. And I made a full flash and found the dtb in boot/dtb still is the dtb what I used in step 2

So, I tried not to clone the system.img instead of using the default rootfs for flashing, and the dtb applied.