All 530 driver versions behave like a virus

I’m not saying they’re a virus but that’s the way all 530 drivers behave in Linux. In Arch, at least. On a fresh system install at first it was OK but then suddenly everything started flashing like in a disco club, the terminal window was both flashing and moving very fast from top right to bottom left corner. I was unable to record a video bc I couldn’t catch up with the terminal window nor open the menu (because of the flashing everything problem). I managed to capture a screenshot which represents a fraction of the second in terminal’s journey from top right to bottom left corner.
The same thing also happens if I update the driver from an Arch system where the driver is 525.89.02 (this version works perfectly fine) and added to ignorepkg, so that it never updates. But if I update it intentionally to 530.41.03-1, the travelling and flashing of windows and stuff starts happening almost immediately after the system reboot.

All drivers before 530 don’t have this problem and work just fine.

My system info in case you need it:

[rado@arch]: ~>$ sysinfo

OS: ArchLinux
Kernel: 6.1.22-1-lts
Uptime: 19 mins
Packages: 1509 (pacman)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: Cinnamon 5.2.7
WM: Mutter (Muffin)
WM Theme: BGT-v1.9 (Cinnamox-Rhino)
Theme: BGT-v1.9 [GTK2/3]
Icons: Humanity-Dark [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i7-4770 (8) @ 3.400GHz
GPU: NVIDIA GeForce GTX 1660 Ti
Memory: 2.90GiB / 31.27GiB (9%)
GPU Driver: NVIDIA 525.89.02
CPU Usage: 5%
Disk (/): 24G / 110G (23%)
Font: Open Sans Semi-Bold 11 [GTK2/3]

Try this.

1 Like

I will, thanks. But for how long this workaround will do the trick - that’s the $1 mil question to NV.

I have such systemd-boot entry:

> cat /boot/loader/entries/1-arch.conf
title   Arch Linux
linux   /vmlinuz-linux
initrd  /amd-ucode.img
initrd  /initramfs-linux.img
options root="LABEL=arch_os" rw nvidia_drm.modeset=1

Doesn’t help. No issues with 525 driver, and there are with 530. Arch Linux.

1 Like

This isn’t where you’re supposed to put the “nvidia_drm.modeset=1” option. It should be in grub.cfg, on the linux line: , then update the driver and reboot. This option does eliminate the virus-like behavior but the driver creates another problem - a persistent 30% load of the GPU which is FAR from normal. With 525 GPU load is rarely above 10%, with 530 it starts at 30%, then suddenly drops down to 20% and then quickly climbing back up to 30%, then repeat. Which is why I froze the version to 525.89.02.
But given the lack of answers here and in my other topic (GPU load 20-30% after driver update) from any nvidia developer, I doubt that they’ll ever fix that and we’ll stick to 525 forever. Personally I think I’ll go back to the stable drivers whose versions are like this - XXX.XX.

GRUB is one boot loader, systemd-boot is another. I don’t have GRUB, and it’s not required for NVIDIA.

You can read this, for example: Arch boot process - ArchWiki

1 Like