Repeated monitor flickering/resync with 310.xx driver on Quantal amd64

Hi,

my setup has a problem with the new 310 series drivers on Ubuntu Quantal, amd64, Gnome Shell. After booting and with start of X the monitor keeps flickering at a rate of nearly 1 Hz. It seems that the sync of the monitor isn’t stable.
The output is garbled when the resync/flicker happend, it seems to be parted in 4 squares.

This problem only occurs with the new 310.xx series, I’ve tested it with 310.14 and 310.19.
All previous drivers are working without problem, tested with 304.51 and earlier

My setup :

Intel Core i7-2600k
GTX 560 TI, 1024 MB
Asus P8Z68-V LX
16 GB RAM
Acer HS244HQ at DFP-2 (HDMI) (3D capable)
Ubuntu Quantal amd64
Gnome 3.60, no Unity

I’ve attached the two bug reports for working and non-working drivers.

It seems that the server refuses to add *.log.gz attachments…how can I upload the log files ?

rename it as JPG and say that ;)

Okay, thank you for the hint. I’ve added the missing log files to the original post.

Maybe there’s a compatibility problem with the monitor ? Unfortunately I haven’t got a second one to test this.

Can you please enable verbose mode validation logging by running “nvidia-xconfig --mode-debug” and then regenerating the logs with both 304.48 and 310.19? Also, can you give 304.64 a try to see if it introduced the same problem?

Thank you for your answer, here the log files for 304.48, 304.64 and 310.19 with debug option enabled. 304.64 works flawlessly.

Today, I connected my 560 TI with 310.19 drivers to the VGA input of the monitor et voila ! It works without the dreaded resync problem. It seems to be a problem of the digital output only. I’ve attached the bug report from the working configuration.

This is only a temporary solution, the display output is much worse…I really hope the next driver version will fix the bug…

Tested it today with the same monitor connected to a different computer, same resyncs/flicker.

The tested setup :

Intel Core 2 Duo T7500
GT8700M, 512 MB
8 GB RAM
Twinview
Seiko/Epson at DFP-0 (internal)
Acer HS244HQ at DFP-2 (HDMI) (3D capable)
Fedora 17, x86_64

I’ve attached the log file with debug option enabled.

Tested it once again with the newly released 313.09 driver…same results, flicker/resyncs on HDMI, no problems with analog input. I’ve attached the new nvidia-bug-report with this driver.

Just for the record : Same hardware, same monitor on HDMI, 310 series driver (310.70) on Windows 7, no problems.

It’s Linux only…

I really hoped that the new released driver would fix my resync/flicker problem, unfortunately it hadn’t. The problem still remains with the 313.18 driver.

Here is the new nvidia-bug-report for this driver with debug option enabled.

Aaron,

it there any progress on nVidia site for this bug ? My first report is over two months old and I understand that this isn’t a high priority regression for nVidia but I haven’t received any feedback from you or nVidia support in general and there were nearly a handful of updates without changes of this bug.

Is there anything I can do to help finding the cause of this bug ?

So, this is it, the curse of proprietary binary drivers on Linux…you’ve found a bug and then you stand in the rain after you’ve reported the bug to the company…you’ll never get any feedback or a solution for this…

I’m really frustrated about nVidia, the binary driver and the way this bug is handled. The gesture and the two words that Linus used to express his opinion about the binary driver situation and nVidias Linux policy is understandable for me now…

Could this be related to my issue with the 310 drivers? http://devtalk.nvidia.com/default/topic/528369/linux/continuous-fake-monitor-connection-disconnections-are-reported-by-the-310-and-newer-drivers/

Sorry for the slow reply. I looked at your logs, but don’t see anything that would indicate why you’re seeing flickering with the new driver and not the old driver. The timings generated by the X driver are identical between the two logs. I also wasn’t able to find your specific monitor to try it, but I’ll keep looking.

We are still not able find exact same monitor…

We are still not able find exact same monitor…

It’s a model from 2010/2011…

http://us.acer.com/ac/en/US/press/2010/3806

I don’t know if it was ever sold in the US.

Could you not just send me some scripts/programs to do some tests to track down the bug for you ? Is there any kind of test suite for the HDMI connection or any tool to display more information about it than the nvidia-bug-report script ?

Working with an digital monitor running in analog mode is very annoying…I would do nearly everything to help you to find the bug.

Hi,
I have that same problem : https://devtalk.nvidia.com/default/topic/528230/-regression-313-18-and-310-32-internal-screen-flickering-dell-e6410-nvs-3100/

I added videos how it look:
https://vimeo.com/62563453
https://vimeo.com/62563452
I have this problem only on internal screen and only when I Use DisplayPort. With VGA connector problem disappear.
I attacher three bug logs:
first, after update to last driver,
second, after switch to vga and back,
third, after switch to DisplayPort and back.

I use IIYama monitor with resolution 1920x1200 and connection DisplayPort to HDMI. Witch older drivers I didn’t have any problems.

[This file was removed because it was flagged as potentially malicious] (105 KB)
[This file was removed because it was flagged as potentially malicious] (111 KB)
nvidia-bug-report3.log.gz (135 KB)

Wodor,

I think it’s another problem. I’ve made a video myself to show the problem that occurs on my setup. Here it is :

The monitor resyncs ar a rate of nearly 1 Hz, see the flashing Infrared LEDs for the 3D glasses at the left bottom of the monitor.