Repeated monitor flickering/resync with 310.xx driver on Quantal amd64

So. I didn’t have any answer from nvidia. It is disappointed.

Tested today with new 319 series driver…and guess what ? The bug is still there, of course…

310.xx
313.xx

and now the

319.xx

drivers…the bug remains, even 7 months after my first bug report…disappointing…

With my BUG is still that same, I’m still waiting for correction. :/

319.17 - Same problem

I have similiar (or same?) Problem with same Monitor https://devtalk.nvidia.com/default/topic/532969/monitor-switches-on-and-off-with-nvidia-drivers-gt-310-19/#3800964

Monitor seems to be sold out but if there is anything I can to to help you fixing that bug I would be glad to

Problem still exists with 319.23 “long-term stable” release driver…still no help or support from nVidia…

Driver 319.32 won’t fix the problem, still no sign of support or help from nVidia… it’s really a shame…

Even the new 325 series driver (325.08) won’t fix the problem, the last working driver is still 304.88 from the 304 series.

310.xx
313.xx
319.xx
320.xx
325.xx

5 complete series of drivers and no fix for something that worked for years without problem…I’m really pissed off nVidia…

Come on, nVidia guys…try to help your customers and don’t ignore their problems with your sh**ty proprietary software !!!

Tested it today without any hope after updating to 325.15…same story. The bug comes near to it’s first birthday…

In the meantime I switched to Nouveau driver where ever possible and bought ATI cards for new purchases of friends and family. The main machine has still the problem, the workaround by using the VGA (analog) connector is more than ugly.

Thank nVidia…for nothing…

wodor, What is make and model IIYama monitor ? Is this also happening with any other GPU ?

HasiPopasi, We are very sorry for that !! We don’t have exact same monitor… Is there any other users also reporting issue for Acer HS244HQ? Also video is not accessible http://youtu.be/yNxnoGnq4nk

Sandip,

first of all: Thank you very much for your reply =)

I deleted the first version of the video because nobody seems to care. Here’s an updated version in HD this time :

http://youtu.be/6QD2ImZWHIY

Is there any possibility to have some (maybe nVidia internal) test tools to track down this bug? I would sign a NDA to help with this. Or any other log files etc. I can send you ?

Any help is appreciated, I would really like to see this long standing bug fixed…

After 10 months of suffering I finally found a workaround for the still existing bug described in this thread :

I created a custom EDID file for the monitor and added the CustomEDID option to the xorg.conf. Now I’ve got a stable monitor output back…good to have this option in the driver…and I really hope this bug get fixed though…

Hi Hasi,

could you please post a small guide how you created that file and how you used it?

Thanks in Advance,

Jonas

Try to save edid of this display from nvidia-settings in gui mode and use the saved edid file with CustomEDID option in xorg.conf.

Option “CustomEDID” “string”

This option forces the X driver to use the EDID specified in a file rather than the display's EDID. You may specify a semicolon separated list of display names and filename pairs. Valid display device names include "CRT-0", "CRT-1", "DFP-0", "DFP-1", "TV-0", "TV-1", or one of the generic names "CRT", "DFP", "TV", which apply the EDID to all devices of the specified type. Additionally, if SLI Mosaic is enabled, this name can be prefixed by a GPU name (e.g., "GPU-0.CRT-0"). The file contains a raw EDID (e.g., a file generated by nvidia-settings).

For example:

    Option "CustomEDID" "CRT-0:/tmp/edid1.bin; DFP-0:/tmp/edid2.bin"

will assign the EDID from the file /tmp/edid1.bin to the display device CRT-0, and the EDID from the file /tmp/edid2.bin to the display device DFP-0. Note that a display device name must always be specified even if only one EDID is specified.

Caution: Specifying an EDID that doesn't exactly match your display may damage your hardware, as it allows the driver to specify timings beyond the capabilities of your display. Use with care.

When this option is set for an X screen, it will be applied to all X screens running on the same GPU.

Hello Sandipt,

I tried that out but this have no affect on me.

See https://codeinbarrels.net/jonas/ablage/xorg.conf for my xorg.conf.

Do I have to modify the edid file? This one is the one beeing generated from nvidia-settings https://codeinbarrels.net/jonas/ablage/dfp0.edid

here a Xorg.0.log (from working 304.108 drivers) https://codeinbarrels.net/jonas/ablage/Xorg.0.log

Just follow the instructions in this file, which is part of the kernel documentation :

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/Documentation/EDID/HOWTO.txt?id=refs/tags/v3.11.2

It’s very easy to compile your own EDID file with your timings then. After you’ve created the BIN file, just do like Sandip said some posts above. It works for me and workarounds the EDID bug in the post-304.xx series drivers.

thank you very much, but where do I get the correct timings from?

would you upload you edid file somewhere? It should be compatibel as you have the exact same monitor than me.

worked with the default 1920x1080 file. Thank everyone for all the help

Still not fixed in 331.13…workaround still works though.

Hey nVidia, I could provide an EDID dump of the monitor to track down the bug in the binary driver…