An Error about my camera module in Jetson TX1

In order to test my camera module,i use the following command:
nvgstcapture-1.0
But the camera didn’t bring bring up,what Terminal shown are being list as following:
Encoder null, cannot set bitrate!
Encoder Profile = Baseline
Supported resolutions in case of CSI Camera
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
(5) : 2104x1560
(6) : 2592x1944
(7) : 2616x1472
(8) : 3840x2160
(9) : 3896x2192
(10): 4208x3120
(11): 5632x3168
(12): 5632x4224

Runtime CSI Camera Commands:

Help : ‘h’
Quit : ‘q’
Set Capture Mode:
mo:
(1): image
(2): video
Get Capture Mode:
gmo
Set Sensor Id (0 to 10):
sid: e.g., sid:2
Get Sensor Id:
gsid
Set sensor orientation:
so:
(0): none
(1): Rotate counter-clockwise 90 degrees
(2): Rotate 180 degrees
(3): Rotate clockwise 90 degrees
Get sensor orientation:
gso
Set Whitebalance Mode:
wb:
(0): off
(1): auto
(2): incandescent
(3): fluorescent
(4): warm-fluorescent
(5): daylight
(6): cloudy-daylight
(7): twilight
(8): shade
(9): manual
Get Whitebalance Mode:
gwb
Set Scene-Mode:
scm:
(0): face-priority
(1): action
(2): portrait
(3): landscape
(4): night
(5): night-portrait
(6): theatre
(7): beach
(8): snow
(9): sunset
(10): steady-photo
(11): fireworks
(12): sports
(13): party
(14): candle-light
(15): barcode
Get Scene-Mode:
gscm
Set Color Effect Mode:
ce:
(1): off
(2): mono
(3): negative
(4): solarize
(5): sepia
(6): posterize
(7): aqua
Get Color Effect Mode:
gce
Set Auto-Exposure Mode:
ae:
(1): off
(2): on
(3): OnAutoFlash
(4): OnAlwaysFlash
(5): OnFlashRedEye
Get Auto-Exposure Mode:
gae
Set Flash Mode:
f:
(0): off
(1): on
(2): torch
(3): auto
Get Flash Mode:
gf
Set Flicker Detection and Avoidance Mode:
fl:
(0): off
(1): 50Hz
(2): 60Hz
(3): auto
Get Flicker Detection and Avoidance Mode:
gfl
Set Contrast (0 to 1):
ct: e.g., ct:0.75
Get Contrast:
gct
Set Saturation (0 to 2):
st: e.g., st:1.25
Get Saturation:
gst
Set Exposure Time in seconds:
ext: e.g., ext:0.033
Get Exposure Time:
gext
Set Auto Exposure Lock(0/1):
ael: e.g., ael:1
Get Auto Exposure Lock:
gael
Set Edge Enhancement (0 to 1):
ee: e.g., ee:0.75
Get Edge Enhancement:
gee
Set ROI for AE:
It needs five values, ROI coordinates(top,left,bottom,right)
and weight in that order
aer: e.g., aer:20 20 400 400 1.2
Get ROI for AE:
gaer
Set ROI for AWB:
It needs five values, ROI coordinates(top,left,bottom,right)
and weight in that order
wbr: e.g., wbr:20 20 400 400 1.2
Get ROI for AWB:
gwbr
Set FPS range:
It needs two values, FPS Range (low, high) in that order
fpsr: e.g., fpsr:15 30
Get FPS range:
gfpsr
Set WB Gains:
It needs four values (R, GR, GB, B) in that order
wbg: e.g., wbg:1.2 2.2 0.8 1.6
Get WB Gains:
gwbg
Set TNR Strength (0 to 1):
ts: e.g., ts:0.75
Get TNR Strength:
gts
Set TNR Mode:
tnr:
(0): NoiseReduction_Off
(1): NoiseReduction_Fast
(2): NoiseReduction_HighQuality
Get TNR Mode:
gtnr
Capture: enter ‘j’ OR
followed by a timer (e.g., jx5000, capture after 5 seconds) OR
followed by multishot count (e.g., j:6, capture 6 images)
timer/multihot values are optional, capture defaults to single shot with timer=0s
Start Recording : enter ‘1’
Stop Recording : enter ‘0’
Video snapshot : enter ‘2’ (While recording video)
Set Preview Resolution:
pcr: e.g., pcr:3
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
(5) : 2104x1560
(6) : 2592x1944
(7) : 2616x1472
(8) : 3840x2160
(9) : 3896x2192
(10): 4208x3120
(11): 5632x3168
(12): 5632x4224
Note - For preview resolutions 4208x3120 and more use option --svs=nveglglessink
Get Preview Resolution:
gpcr
Set Image Resolution:
icr: e.g., icr:3
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
(5) : 2104x1560
(6) : 2592x1944
(7) : 2616x1472
(8) : 3840x2160
(9) : 3896x2192
(10): 4208x3120
(11): 5632x3168
(12): 5632x4224
Get Image Capture Resolution:
gicr
Set Video Resolution:
vcr: e.g., vcr:3
(2) : 640x480
(3) : 1280x720
(4) : 1920x1080
(5) : 2104x1560
(6) : 2592x1944
(7) : 2616x1472
(8) : 3840x2160
(9) : 3896x2192
Get Video Capture Resolution:
gvcr

Runtime encoder configuration options:

Set Encoding Bit-rate(in bytes):
br: e.g., br:4000000
Get Encoding Bit-rate(in bytes):
gbr
Set Encoding Profile(only for H.264):
ep: e.g., ep:1
(0): Baseline
(1): Main
(2): High
Get Encoding Profile(only for H.264):
gep
Force IDR Frame on video Encoder(only for H.264):
Enter ‘f’

bitrate = 4000000
Encoder Profile = Baseline
Socket read error. Camera Daemon stopped functioning…
gst_nvcamera_open() failed ret=0

** (nvgstcapture-1.0:2637): CRITICAL **: <create_capture_pipeline:4565> can’t set camera to playing

** (nvgstcapture-1.0:2637): CRITICAL **: main:5367 Capture Pipeline creation failed
** Message: main:5374 Capture completed
** Message: main:5424 Camera application will now exit

Then ,I use the following command;
nvidia@tegra-ubuntu:~$ v4l2-ctl --list-devices
Failed to open /dev/video0: No such file or directory

Then,I input dmesg|grep -i ov5693,and nothing show up.

I can find ov5693.c in kernel/kernel-4.4/drivers/media/i2c/ov5693.c

Please tell me how can I get my camera work.Thanks a lot!

I trying to build Kernel to fix it,but when I use https://github.com/jetsonhacks/buildJetsonTX1Kernel to build my kernel,I find an option contain the character"ov5693" and choose it ,but when I make the kernel,I received the following error:

ERROR: “camera_common_g_mbus_config” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_create_debugfs” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_parse_ports” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_s_power” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_regulator_get” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_parse_clocks” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “regmap_util_write_table_8” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_g_ctrl” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_g_fmt” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_s_fmt” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_try_fmt” [drivers/media/i2c/ov5693.ko] undefined!
ERROR: “camera_common_remove_debugfs” [drivers/media/i2c/ov5693.ko] undefined!
scripts/Makefile.modpost:91: recipe for target ‘__modpost’ failed
make[1]: *** [__modpost] Error 1
Makefile:1130: recipe for target ‘modules’ failed
make: *** [modules] Error 2
INSTALL crypto/cmac.ko
INSTALL crypto/drbg.ko
INSTALL crypto/echainiv.ko
INSTALL crypto/jitterentropy_rng.ko
INSTALL crypto/md4.ko
INSTALL crypto/sha256_generic.ko
INSTALL crypto/tcrypt.ko
INSTALL drivers/bluetooth/hci_uart.ko
INSTALL drivers/media/i2c/ov5693.ko
cp: cannot stat ‘drivers/media/i2c/ov5693.ko’: No such file or directory
INSTALL drivers/media/platform/soc_camera/soc_camera.ko
cp: cannot stat ‘drivers/media/platform/soc_camera/soc_camera.ko’: No such file or directory
INSTALL drivers/media/platform/soc_camera/soc_camera_platform.ko
cp: cannot stat ‘drivers/media/platform/soc_camera/soc_camera_platform.ko’: No such file or directory
INSTALL drivers/media/platform/soc_camera/soc_mediabus.ko
cp: cannot stat ‘drivers/media/platform/soc_camera/soc_mediabus.ko’: No such file or directory
INSTALL drivers/media/usb/gspca/gspca_main.ko
INSTALL drivers/media/usb/gspca/gspca_zc3xx.ko
INSTALL drivers/media/usb/uvc/uvcvideo.ko
INSTALL drivers/media/v4l2-core/videobuf-core.ko
cp: cannot stat ‘drivers/media/v4l2-core/videobuf-core.ko’: No such file or directory
INSTALL drivers/media/v4l2-core/videobuf2-vmalloc.ko
INSTALL drivers/misc/bluedroid_pm.ko
INSTALL drivers/net/ethernet/intel/e1000e/e1000e.ko
INSTALL drivers/net/ethernet/intel/igb/igb.ko
INSTALL drivers/net/ethernet/realtek/r8169.ko
INSTALL drivers/net/wireless/bcmdhd/bcmdhd.ko
INSTALL drivers/pps/pps_core.ko
INSTALL drivers/ptp/ptp.ko
INSTALL drivers/video/backlight/lcd.ko
INSTALL drivers/video/backlight/pwm_bl.ko
INSTALL fs/cifs/cifs.ko
INSTALL net/bluetooth/bluetooth.ko
INSTALL net/bluetooth/bnep/bnep.ko
INSTALL net/bluetooth/hidp/hidp.ko
INSTALL net/bluetooth/rfcomm/rfcomm.ko
INSTALL net/bridge/br_netfilter.ko
DEPMOD 4.4.38-tegra

I am trying to get my NVIDIA TX1 working for the first time and going through, line-by-line, the system setup described here: https://github.com/dusty-nv/jetson-inference#system-setup.

Everything works until I get to the “Running the Live Camera Recognition Demo”

When I use:
$ ./imagenet-camera googlenet

I see:


imagenet-camera: successfully initialized video device

[gstreamer] gstreamer transitioning pipeline to GST_STATE_PLAYING
Socket read error. Camera Daemon stopped functioning…
gst_nvcamera_open() failed ret=0
[gstreamer] gstreamer failed to set pipeline state to PLAYING (error 0)

imagenet-camera: failed to open camera for streaming

Has anyone been able to fix this problem?
Help!

RESOLVED:
I can confirm that Nvidia moderator JerryChang’s response here fixed my issue:
https://devtalk.nvidia.com/default/topic/1019986/jetson-tx1/getting-errors-in-using-onboard-camera-jetpack-3-1-/post/5203796/#5203796