Error accessing camera on TX2

Hi,

I just received my TX2 developer kit and when I try to use the onboard camera I get an error. I’ve tried with different demos. They all give me the same error in dmesg:

[ 1398.948556] CPU: 5 PID: 7584 Comm: nvcamera-daemon Not tainted 4.4.15-tegra #1
[ 1398.948559] Hardware name: quill (DT)
[ 1398.948563] task: ffffffc17da2f080 ti: ffffffc1b256c000 task.ti: ffffffc1b256c000
[ 1398.948567] PC is at 0x7f9baa486c
[ 1398.948570] LR is at 0x7f9baa47e8
[ 1398.948573] pc : [<0000007f9baa486c>] lr : [<0000007f9baa47e8>] pstate: 80000000
[ 1398.948575] sp : 0000007fd22a8e20
[ 1398.948577] x29: 0000007fd22a9000 x28: 0000000000000001 
[ 1398.948581] x27: 000000000000000c x26: 000000000000000c 
[ 1398.948585] x25: 0000000000000001 x24: 0000000000000003 
[ 1398.948589] x23: 0000007f9bb1c710 x22: 0000007fd22a9758 
[ 1398.948592] x21: 0000000000000008 x20: 0000000000000003 
[ 1398.948596] x19: 0000000000000001 x18: 0000000000000010 
[ 1398.948599] x17: 0000000000000008 x16: 0000000000000004 
[ 1398.948602] x15: 0000000000000003 x14: 0000000000000004 
[ 1398.948606] x13: 0000000000000003 x12: 0000000000000001 
[ 1398.948609] x11: 0000000010020000 x10: 0000000000000010 
[ 1398.948612] x9 : 0000000000000005 x8 : 0000000000000001 
[ 1398.948616] x7 : 0000000000000000 x6 : 0000000000000008 
[ 1398.948619] x5 : 0000000000000007 x4 : 0000000000000008 
[ 1398.948622] x3 : 0000000000000016 x2 : 0000000000000011 
[ 1398.948625] x1 : 0000007f9bafe620 x0 : 0000007f9bb1ecd8 

[ 1398.948634] Library at 0x7f9baa486c: 0x7f9baa0000 /usr/lib/aarch64-linux-gnu/tegra/libnvidia-glsi.so.27.1.0
[ 1398.958383] Library at 0x7f9baa47e8: 0x7f9baa0000 /usr/lib/aarch64-linux-gnu/tegra/libnvidia-glsi.so.27.1.0
[ 1398.968128] vdso base = 0x7f9da85000

The demo I’ve tried to get working the most is this https://github.com/dusty-nv/jetson-inference one.

The error I get from it is:

[cuda]  cudaAllocMapped 8192 bytes, CPU 0x102a02000 GPU 0x102a02000
[gstreamer] gstreamer transitioning pipeline to GST_STATE_PLAYING
[gstreamer] gstreamer failed to set pipeline state to PLAYING (error 0)

imagenet-camera:  failed to open camera for streaming

Not sure where to go from there!

Cheers,

Ugo

hello ugocupcic,

are you able to launch camera by other application?

for example.

v4l2-ctl -d /dev/video0 --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=10 --stream-to=test.raw

or

gst-launch-1.0 nvcamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12' ! nvoverlaysink -ev

Hello JerryChang,

The gst-launch complains about WARNING: erroneous pipeline: no element “nvoverlaysink”

The v4l2 command seems to work but when I open the test.raw file that’s been created I only see some green noise. I use the following command to open the file:

mplayer test.raw -demuxer rawvideo -rawvideo w=1920:h=1080

You can find the file here: https://drive.google.com/file/d/0B–hrBUcsTNQaUJnN09lZWNnRWM/view?usp=sharing

Cheers,

Ugo

I just tried this pipeline

gst-launch-1.0 nvcamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12' ! nvoverlaysink -ev

I got a: WARNING: erroneous pipeline: could not link nvcamerasrc0 to nvoverlaysink-nvoverlaysink0

I then tried the V4L2 pipeline and ran the mplayer test and saw the ‘green snow’

After that I ran

nvgstcapture-1.0

I can view the video live from the onboard camera

Hey,

So I gave nvgstcapture-1.0 a try and I get the following error:

Runtime encoder configuration options:

  Set Encoding Bit-rate(in bytes):
      br:<val> e.g., br:4000000
  Get Encoding Bit-rate(in bytes):
      gbr
  Set Encoding Profile(only for H.264):
      ep:<val> e.g., ep:1
          (0): Baseline
          (1): Main
          (2): High
  Get Encoding Profile(only for H.264):
      gep
  Force IDR Frame on video Encoder(only for H.264):
      Enter 'f'


Encoder null, cannot set bitrate!
Encoder Profile = Baseline

** (nvgstcapture-1.0:2332): ERROR **: <get_video_encoder:2031> Can't Create video encoder element

Trace/breakpoint trap (core dumped)

hello ugocupcic,

seems your camera function not works.
may i confirm below 2 questions?

  1. which JetPack version you were using?
  2. which camera mounted? please share the part# on the camera module.
    thanks

Hi JerryChang,

I’m using the Jetson TX2 developer kit.

There are a few numbers on the camera module as you can see here https://goo.gl/photos/8ZDJPyiePEH5VVPf8

Cheers,

hello ugocupcic,

could you please run the launching camera failure use-case again and gather the kernel message,
please also keep the kernel message from the system booting stage. thanks

dmesg > logcat.txt

Hi JerryChang,

Here are my logs:

dmesg > log.txt

https://transfer.sh/Y03Ek/log.txt

/var/log/syslog

https://transfer.sh/MaqR/syslog

Cheers,

Ugo

I’m having issues with a Zed camera and a usb webcam on software I’ve been running on the TX1 with no issues. Ros-kinetic-usb_cam. The Zed sdk was just released however on the TX2 I have it also fails. The usb_webcam puts out one image then goes dark. The Zed doesn’t come up at all. Something seems funky with video4linux.

hi ugocupcic,

according to the attachment, i saw the nvcamera-daemon service keep crashing, nvcamera-daemon is the background service for handling camera pipeline.
could you please try to stop the default service and launch nvcamera-daemon manually, this may provide more information.

  1. please stop default service
$ sudo service nvcamera-daemon stop
  1. run nvcamera-daemon service manually
$ sudo /usr/sbin/nvcamera-daemon &

hello danpollock,

may i know what’s your commands to launch Zed camera and kinetic usb camera?
since this topic is talking about default onboard camera, i would suggest you file a new topic for tracking dual camera use-case. thanks

Hi JerryChang,

The nvcamera-daemon segfaults after a second without running anything else.

sudo /usr/sbin/nvcamera-daemon
Segmentation fault (core dumped)

You’ll find the coredump over here: https://transfer.sh/nqE0o/core

Cheers,

hello ugocupcic,

there’s another framework could access camera too, could you please take a try to access camera via mm api to help us narrow down the issue.
you’re able to download the L4T Multimedia API Reference from Embedded Download Center for reference.
thanks

Hi JerryChang,

I tried the 09_camera_jpeg_capture sample in the l4t multimedia API and I still get a segfault. When looking at dmesg after that segfault I always get back to the same error:

[  370.620699] CPU: 4 PID: 3515 Comm: camera_jpeg_cap Not tainted 4.4.15-tegra #1
[  370.620704] Hardware name: quill (DT)
[  370.620710] task: ffffffc1eeace400 ti: ffffffc1eb5c4000 task.ti: ffffffc1eb5c4000
[  370.620717] PC is at 0x7fa7a8f86c
[  370.620720] LR is at 0x7fa7a8f7e8
[  370.620725] pc : [<0000007fa7a8f86c>] lr : [<0000007fa7a8f7e8>] pstate: 80000000
[  370.620728] sp : 0000007ffee37710
[  370.620732] x29: 0000007ffee378f0 x28: 0000000000000001
[  370.620739] x27: 000000000000000c x26: 000000000000000c
[  370.620744] x25: 0000000000000001 x24: 0000000000000003
[  370.620750] x23: 0000007fa7b07710 x22: 0000007ffee38048
[  370.620764] x21: 0000000000000008 x20: 0000000000000003
[  370.620769] x19: 0000000000000001 x18: 0000000000000010
[  370.620775] x17: 0000000000000008 x16: 0000000000000004
[  370.620780] x15: 0000000000000003 x14: 0000000000000004
[  370.620785] x13: 0000000000000003 x12: 0000000000000001
[  370.620790] x11: 0000000010020000 x10: 0000000000000010
[  370.620796] x9 : 0000000000000005 x8 : 0000000000000001
[  370.620800] x7 : 0000000000000000 x6 : 0000000000000008
[  370.620805] x5 : 0000000000000007 x4 : 0000000000000008
[  370.620810] x3 : 0000000000000016 x2 : 0000000000000011
[  370.620815] x1 : 0000007fa7ae9620 x0 : 0000007fa7b09cd8

[  370.620828] Library at 0x7fa7a8f86c: 0x7fa7a8b000 /usr/lib/aarch64-linux-gnu/tegra/libnvidia-glsi.so.27.1.0
[  370.630582] Library at 0x7fa7a8f7e8: 0x7fa7a8b000 /usr/lib/aarch64-linux-gnu/tegra/libnvidia-glsi.so.27.1.0
[  370.640344] vdso base = 0x7fa9e28000

(even if I kill the nvcamera-daemon first)

Cheers

hello ugocupcic,

since L4T MM API works with other forum users,
i would suggest you reinstall JetPack 3.0 and flash the device again.
thanks

Hi JerryChang,

Sorry for the long silence, I just had time to reflash my Jetson TX2 with the latest JetPack 3.0 and it did fix it. For some reason I can’t find a way to accept your latest suggestion as solving the problem :S

Thanks

Ugo