Another error 43 in esxi but

I should not encounter this problem, but i can’t find a solution. I have been searching since yesterday morning.
Esxi 7.2 host.
Guest os: windows server 2022/2019 eval fresh install.
Gpu for passthrough: quadro p400
After a fresh install of the guest os and only the nvidia driver package 528.49 for win server 2022/2019 64bit version i get the gpu installed but it is disabled with an error code 43.

On the same host i have an older win 2019 vm which works great with this gpu in passthrough mode.
I did also try to add the advanced parameter ‘hypervisor.cpuid.v0’ as FALSE although this should not be needed anymore, as this is a quadro gpu and now nvidia will not usually block gpu in vm enviroment.

So i have already installed 2 new vms with different oses that act abnormally.

Any hint as to what i could try next?


Just to keep track of the evolution on this matter:

For the issue of not being able to start the vm after a host restart, one needs to apply:
esxcli system settings kernel set -s vga -v FALSE
in the esxi host console. (according to this: Passthrough of Integrated GPU (iGPU) for standard Intel NUC)

After this, I tried following the tutorial here without any luck:
BUT it got me thinking about one thing. Maybe a monitor connected while powering up the HOST would do a difference? and yes, it DID.

I managed to start the host with a dummy plug in the dedicated gpu, drivers installed, all ok. The issue is still that on the old vm I do not need a dummy monitor plug. I think it might be an issue with setting the main display unit to use in the host’s bios. Because now it is working for me, I will not investigate this further.

  • I still can restart the vm as many times I want without needing to restart the host in order to use the dedicated, passthrough gpu.

My next issue is that I am now not able to remote connect to the guest windows server 2022 vm while the dedicated gpu is available. I tried disabling Use WDDM graphics display driver for Remote Desktop Connection as per but this only gets rdp working while the dedicated gpu is disabled. if it is enabled , I still get an error ‘The graphics display components in the remote session failed to start up. Error code 0X11’

Updated drivers to latest version again, and now remote desktop is also working.