Power off or Reboot Ubuntu VM with GPU Passthru disables GPU

Hello I seem to have run into a fun issue. I am attempting to setup a ubuntu VM with a Quadro P4000 and I’ve run into an issue once drivers load in the VM. From what I can tell this doesn’t matter if the Guest OS is Server or Desktop. Here are the details of my environment

Host: Windows Server 2016 Core
GPU: Quadro P4000
Guest: Ubuntu 20.04

I have an app that can run in Windows or Linux, this app uses ffmpeg for decoding/encoding videos. The Linux version handles videos with HDR on the gpu where the windows version will use CPU for the HDR portion. So I am doing some testing before making the full move.

I currently have the GPU passed into a Windows Guest. Works great rebooting the vm card starts no problem extra.

So Installed, Ubuntu Desktop first, installed the app and copied some videos that are 4K HDR for testing. Without the GPU the app was working without issue as best it could CPU rendering the videos pegs the vm cpu. So I shut down both the windows guest and ubuntu guest. removed the P4000 from the Windows VM and attached it to the Ubuntu VM. Powered on, installed drivers, rebooted. Got No display on the VM…(I should have expected that actually). removed the card to install SSH Server so I can at least have terminal. After powering back up I had display on the vm and testing the app would through errors trying to start it’s encoding/decoding process. So while trying to figure out why I was having issues with the app in linux I put the GPU back to the Windows Guest and powered it back on. Only to find it wasn’t working either now. In Device manager the card had a code 43 error. after failing to get the device to start in windows I decided to reboot the entire host. Which solved the issue with the windows guest. So I decided to got back to my testing of the Ubuntu Guest and I was able to get everything to work (no display on the VM still), but I wasnt’ done. I wanted to test the functionality on Ubuntu Server as well so I powered off the Ubuntu Guest, Swithed VHD’s to the server and powered it on and same thing again won’t run the app’s process and the Windows Guest again has code 43 error.

In linux I was using the 510 driver package, on windows i’m using a 47X driver. I’ve not tired with the 470 driver package on Linux yet, but I am planning on it. But my question is, is there a setting in the linux drivers that cause a part of the card to stop that is reset during reboot of the physical machine. And if there is, how do I disable it. Or is the an issue with the 510 package.


Windows Server Core OS is not supported at all as a host. Most likely causes the issues…