Another slow booting problem with Nvidia in Ubuntu 20.04, systemd says 18s, my stopwatch says 1m20s

I recently installed Nvidia (version 460 according to recommended version by Ubuntu) and Cuda. Here’s my Nvidia & Cuda version :

 NVIDIA-SMI 460.39       Driver Version: 460.39 

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2021 NVIDIA Corporation
Built on Thu_Jan_28_19:32:09_PST_2021
Cuda compilation tools, release 11.2, V11.2.142
Build cuda_11.2.r11.2/compiler.29558016_0

I am using Ubuntu 20.04. Prior installing Nvidia, my system would boot in under 20 seconds. After Nvidia, it boots in 1 minutes 20 seconds (checked using stopwatch). I was afraid it wouldn’t boot, but it boots after all, just really really slow. Funny thing, systemd-analyze time didn’t even catch it correctly, it says my boot time was just 18 seconds :

Startup finished in 5.426s (firmware) + 5.069s (loader) + 2.432s (kernel) + 6.027s (userspace) = 18.955s 
graphical.target reached after 5.461s in userspace

At first I though it was because of Snap, so I uninstalled VLC and Mailspring from snap hoping it would get a bit faster, but nothing changes, they weren’t the culprit. I’m using exactly the same snaps before installing Nvidia and my system still would boot fast, so the problem might be Nvidia. I came across this post Ubuntu gets very slow and freeze after installing nvidia drivers, but there’s no solution there as well. Literally all other forums suggested to purge Nvidia, but I need to use it for working purpose, therefore I posted here.

If this helps, this is my current grub settings :

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi pci=noaer video=SVIDEO-1:d rd.plymouth=0 plymouth.enable=0 acpi_enforce_resources=lax intel_pstate=disable acpi_osi="
GRUB_CMDLINE_LINUX=""

Here’s the nvidia log attachment, and nvidia-installer.log nvidia-installer.log (1.9 KB)
nvidia-bug-report.log.gz (322.0 KB)

Please remove all the extra kernel parameters, those are hiding the real cause. I guess you added them because the crappy realtek wifi wouldn’t work otherwise? That might be the real cause. Please try to disable it in bios for testing. First of all, please update your bios.
Once done, please create a new nvidia-bug-report.log.

No, actually all those kernel parameter I’ve added because my notebook would stuck at booting at first, Stackoverflow says it’s because Nvidia. But I’m willing to try, so I will try to disable it. But first, I’m not familiar with updating bios, I’m gonna look for some more information on it and then do as you suggested. I’ll let you know, thank you.

[Update]
Apparently Asus website only provide windows installer for their BIOS updates, is is possible to skip this BIOS update and get to the kernel settings ? Will BIOS matter at this point ?

Here’s the manual of your notebook
https://dlcdnets.asus.com/pub/ASUS/nb/X550VX/0409_E11160_X550VX_A.pdf
It describes how to update the bios from within the bios (no windows required) and how to disable the wireless and other devices.

Yes, I’ve been trying to do it within BIOS as well. Exactly at point no. 6 “Locate your BIOS file” won’t work since Asus only provided .exe file, no .CAP file whatsoever and Easy Flash needs .CAP file. Therefore the only way to install .exe is via FreeDOS. I’ve spending the whole day, hours and hours trying to update it :

  1. Problem in burning bootable FreeDOS,
  2. BalenaEther won’t read FreeDOS ISO file (says “not a bootable image”, I’ve downloaded iso files 4 times from 3 different sources).
  3. Using command dd kills one of my USB already.
  4. Can boot into FreeDOS with Unetbootin, but it won’t change drive let alone read BIOS file. (says drive is invalid) – Never mind, I was finally able to mount my USB, but when I tried to install the update it says “This program must be run under Win32”, so this BIOS update files from ASUS is sadly created for Windows only.

Please let me know if there’s any way I can do this without updating my BIOS. I’m feeling like losing my mind already, I’ll update you when I can finally update my BIOS.

NEVERMIND I’VE UPDATED IT. Here’s my new BIOS :
X550VXK.307
04/19/2019

I am now going to disable booting parameters and see if it still can boot, then I’ll reupload Nvidia bug report

Try removing these first as some DM’s wait for the plymouth quit signal.

rd.plymouth=0 plymouth.enable=0

Also look at

systemd-analyze critical-chain

as it might reveal the cause of the delay.

I removed everything, it’s been 8 minutes and won’t boot at all :) Gonna put those parameters back in grub and remove only those 2 parameters as you suggested.

As for systemd-analyze, I tried with blame and it blames Snap basically. However it always blamed Snap and still would boot fast prior to Nvidia install, I haven’t added any new program via snap so I doubt it’s Snap. But I’ll post Critical Chain once I can boot into my system.

‘systemd-analyze blame’ is lame :-)

Update : Can’t boot into system or into grub2 at all :)

Can boot to a live image on a thumb-drive?

I tried countless parameter combinations with no luck, it just won’t boot. To the point when I actually put exactly the same grub setting parameter I had before, and surprisingly it still won’t boot. Guess I’m screwed now. I’m stuck on black screen with blinking cursor for hours now.

All online forums I’ve check for this black screen issue blame Nvidia and suggested to purge it. I don’t know what’s going on, it booted just fine after BIOS update. I’ll continue again later after some rest, I’ll keep you guys updated. Thanks for replying again.

If you press Ctrl-Alt-F2 (or F3, or F4, …) at the screen with the blinking cursor, do you get a login prompt?

tty with username & password? Yes, I can access that. Is there anything else I can do via tty ?

That’s good! Can you generate a bug report log from there and then use scp or similar to copy it over to a machine you can use to post it here?

Oh, yes I think I can. Do you need the current state (my system with all kernel parameters as before but won’t boot ? ) . Or do you need less kernel parameters ? I’ve been running the script, is it normal for it to take around 3 minutes already ? The first one I’ve uploaded just took me a few seconds.

Here’s the new bug report, it took me 7 minutes to run this according to my terminal. Please let me know if there’s any way to fix my machine. It’s 1 out of 6 attempts for me to be able to boot. If this information necessary, I’m using exactly the same kernel parameter as the original (my first post), also during booting there were countless of black screen splashes, maybe 4-5 times.
[Update] It took me 2m16s to boot.

I have also uploaded systemd-analyze critical-chain information in case it’s necessary.
systemd-analyze critical-chain.txt (763 Bytes)
nvidia-bug-report.log.gz (320.3 KB)

You’re getting an interrupt storm but since you have pci=nomsi set, it’s impossible to say which device is malfunctioning. Please remove that parameter.
Also, since your realtek wifi is known to behaving bad, please try disabling it in bios for testing.

It won’t boot.
I ended up spending hours yesterday trying kernel parameter combinations. Removing either nomsi or noaer and it will stuck on booting screen.

Then please also remove “quiet splash” so you might be able to see what’s goig on. Did you disable the wifi?