Any chance of making hibernation works on Ubuntu 18.04?

This is an old issue I’ve been fighting with for months. First trying to hibernate with the "hibernate"command or pm-hibernate would hang on the screen:

s2disk: Snapshoting to disk

While with the intel prime mode selected instead, with the nvidia drivers not running hibernation would work normally.
With the new kernel 4.19.2 and driver 410.73 things got a bit better! Now the system doesn’t hang on trying to snapshot the disk and fully saves everything to the swap and the computer turns off. But it hangs on trying to restore or awake from hibernation.

I have a nvidia gtx1050 ti on a dell laptop. Ubuntu 18.04 kernel 4.19.2 driver 410.73.

The problem is really easy to reproduce (I guess everyone has it) just need to enable hibernation on ubuntu and try to with the nvidia drivers running.

I have no idea of how to get useful information of this problem but having this would be really usefull to me since I’d like to switch between two dual boot OS’s that can fully use my hardware recovering from a snapshot, so how to gather more info or maybe fix it? Is it a known issue? Are there any plans to fix?

If you don’t game, maybe you should give the nouveau driver a try because it usually works much better in regard to suspend/hibernate.

Well I game a bit but use it mostly for cuda and rendering with blender… Hibernating is not more important to me than those but would still help! I’ve seen progress on this so I thought it could be already working…

I am in the exact same situation.
Did you manage to resolve the issue some how?

Yes! First I uninstalled uswsusp and that basically did it! Right now I am on kernel 5.0.0-31-generic, 18.04.3 LTS, with nvidia driver 435.21. Hibernation works just fine.

That is good to hear! :-)

What are you using to hibernate? systemctl hibernate?

I am on Debian 10 (kernel 4.19) and nvidia driver 435.21 and cannot get hibernation to work. It did however work om Debian 9 before I decided to upgrade.

Both systemctl hibernate and pm-hibertane works. I would suggest you trying a different/newer kernel, making sure your swap partition works and has enough space, and removeing uswsusp if you have it.
I know how annoying that is… I had this issue for months and months

Thank you for the answer!

I removed uswsusp and installed pm-utils instead. Then I ran pm-hibernate. To my big surprise the computer hibernated and I were able to resume to! :-)

Problem solved!
Thanks again!