Resume from hibernation fails with 510.60.02

With the 510.54 driver, hibernation works fine. When resuming, I get a flashing cursor for a bit, then the desktop appears.
With the 510.60.02 driver, resuming from hibernation fails. I get the flashing cursor as before, but then the monitors just turn off. At this point, I can ping the machine, but I cannot login via SSH. Trying to switch to a console with Ctrl-Alt-F1/2/etc doesn’t do anything. After rebooting I don’t see anything in the logs after the start of the hibernation.

I’ve attached pre- and post-hibernate reports with the 510.54 driver, and a pre-hibernate report with the 510.60.02 driver. Obviously I can’t get a post-hibernate report with 510.60.02…

I’ve performed some of the tests suggested here Debugging hibernation and suspend — The Linux Kernel documentation

  • All the hibernation test modes (/sys/power/pm_test) work.
  • Writing test_resume to /sys/power/disk does not work.

510.54-post-hibernate-nvidia-bug-report.log.gz (266.9 KB)
510.54-pre-hibernate-nvidia-bug-report.log.gz (221.6 KB)
510.60.02-pre-hibernate-nvidia-bug-report.log.gz (229.1 KB)

1 Like

Not sure if related but try this solution, it did fix mine [FIXED] Suspend / Resume issues with the driver version 470 - #3 by humblebee

Thanks for the suggestion! I do not have the nvidia-suspend/hibernate/resume services enabled, however I do have /usr/lib/systemd/system-sleep/nvidia which AIUI performs the same job as the nvidia-resume service. I tried removing this. Unfortunately it had no effect, so I suspect this is not the issue. The linked thread talks about a kernel panic, which I do not believe I am seeing – the machine still eg responds to pings, it just seems it doesn’t get far enough through the resume process to allow any real interaction.

Still seeing this with 515.43.04.

I also meet the problem under 510.60.02.

@zdave
I have gone through the original post and it appears that with driver 510.60.02, your system is pinging but display doesn’t comes up post suspend / resume operation.
If you can ssh to machine and capture nvidia bug report with -logverbose 6 / ModeDebug “true” (prior reboot), that would be really helpful for triage purpose.

@zhangliao714
Can you also capture bug report with -logverbose 6 / ModeDebug “true” from repro state (prior reboot) and share on this thread.

Hi, I’m also having this problem on Ubuntu 22.04 with gtx 1650ti mobile, driver version 510.73.05. I attached the nvidia-bug-reports pre suspend and after suspend, with x server running with -logverbose 6 hopefully, not sure if I did it correctly.
pre_suspend.gz (992.8 KB)
after_suspend.gz (993.4 KB)

It’s more than just the display not coming up. As noted in the original post, I cannot SSH into the machine after resume. Possibly it doesn’t get far enough through the resume process to wake the SSH daemon. It seems that resume also doesn’t get far enough for logs etc to get persisted to disk, so I’m not sure how to get any information out that might give clues as to why resume is failing.

Also note that it is hibernate+resume that goes wrong, not suspend+resume; suspend+resume seems to work.

@zdave did you find a workaround for this? I am having the same issue (test with 5.10 and 5.15)

Unfortunately no; I’ve just stuck with 510.54 for now.

I had this same problem and install 510.54 as a workaround. Worked like a charm. Thanks for the tip!!!

Still seeing this with 515.65.01. Is there anything I can do to help get this fixed? It’s preventing me from updating the driver and the kernel (the 510.54 release doesn’t work on 5.18+ AFAICT).

Still seeing this with 515.76.