Broken resume from suspend, F35


Since a recent update of some packages (I do not remember which), I suffer screen corruption on resume: I need to login and kill -3 gnome-shell everytime.
Since a couple of days, it is getting worse, machine does not resume from suspend: I need to force power down and reboot.

I tried to fix as suggested by humblebee at this post, but it does not help. (indeed, it even seems that machine does not go to sleep, if I try I just get a black screen but I may hear that fans are still working).

Machine specs:
OS: Fedora 35
Kernel: 5.17.11-200.fc35.x86_64
GPU: NVIDIA Corporation GM206 [GeForce GTX 950]
NVDIA driver (from NVIDIA Settings): 510.60.02
also $ loginctl show-session 2 -p Type >> Type=x11

help is welcome.
thanks cheers

I update drivers to 510.68.02. Now if I try to suspend, machine restart (show login).
Help is welcome.

I tried again (not resume)

systemctl enable nvidia-suspend.service
systemctl enable nvidia-hibernate.service

and after a couple of reboots, it works!!!

Nope, I am back to not working. I am not sure why, since last time I did not update anything.
thanks cheers