Resume from suspend broke after upgrading to a 1060

On Fedora 25 - Gnome Shell (on Wayland)

I was using a 560 ti for years without any issue. But after upgrading to a 1060 resume from RAM doesn’t work anymore.

It resumes, and then after few seconds the Gnome Shell stops responding. The keyboard hangs, e.g. the num lock doesn’t go off. If I tried to change tty (ctrl-alt-f2 ), after few seconds, the screen goes off.
In dmesg I see XID errors .

Attached the nvidia-bug-report in case it helps.

nvidia-bug-report.log.gz (93.6 KB)

The last couple of pages may prove to be helpful:

(SOLVED) resume from suspend not working with 980 Ti, drivers 352 - 370, kernels 3.16 - 4.4 - NVIDIA Developer Forums
https://devtalk.nvidia.com/default/topic/919984/linux/-solved-resume-from-suspend-not-working-with-980-ti-drivers-352-370-kernels-3-16-4-4/6

Thanks I will try and let you know.

Although till (after upgrading to the latest drivers) now suspending and resuming works until I run Chrome. Specifically something heavy like Google Photos.
I guess at that point Chrome might use OpenGL or something which triggers the issue.

nvidia-bug-report.log.gz (92.9 KB)

Nope. :(

Removed all related CUDA libs.
I already had the parameters to disable nouveau in GRUB and modprobe.

I can resume/suspend multiple times until I get to use something “heavy”.
Note that “heavy” stuff, even games, work fine after a reboot.

And I don’t have a Skylake CPU. I had a 560 Ti on the same system which worked fine.

nvidia-bug-report.log.gz (92.2 KB)

Have you tried starting a thread here as well?

Fedora Forum
https://www.linuxquestions.org/questions/fedora-35/

No, I will post there as well thanks.

Also disabled CSM from BIOS, still no luck. :(

Did you see Xid in log? Please provide nvidia bug report as soon as issue repro.

We are tracking this issue under bug 200273112 : linux eu/oem: Desktop and Applications freeze once resume from suspend with Xid 56 with GTX-1060