Suspend does not work with version 3:470.63.01-3.fc33 of driver on fedora 33

Expected behaviour: invoking # systemctl suspend makes the laptop go to suspend
Actual behaviour: invoking # systemctl suspend makes systemctl log brefly appear on screen (as if the laptop was powering off), then brings me to the login screen.

Downgrading to version 3:455.28-1.fc33 makes suspend work.

Some days ago I followed this guide because suspend was not working anymore after another update.
I suspect that the files mentioned in that guied are missing for some reason in version 470, which causes the suspend to break.

Feel free to write me if more details are needed. Thank you for your attention.

EDIT: I tried to downgrade driver running sudo dnf install xorg-x11-drv-nvidia-3:455.28-1.fc33 but it seems that this caused to unload the driver, because running nvidia-settings from terminal outputs:

$ nvidia-settings 

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

So i think that unloading the driver is a workaround too

hey @daniregna98,
I ran into the same situation on my Fedora 34 setup. After going through nvidia packages from dnf found that there is one package called xorg-x11-drv-nvidia-power .
Upon installing that, nvidia-suspend.service & nvidia-resume.service files were back in system.

Please give it a try followed by :

systemctl enable nvidia-suspend.service
systemctl enable nvidia-resume.service

Looks like someone at nvidia forgot some stupid detail (lol)