Xorg-x11-drv-nvidia-470.63.01-1.fc33.src.rpm crashes when "systemctl suspend" GTX1650

Hi everyone,

I just bought a laptop with dedicated Nvidia GTX 1650 card.

Everthing worked fine with driver version 470.57.02 for Fedora Linux.

I updated to the latest one, version 470.63.01 and when I try to put the laptop in suspend mode, both monitors (the laptop integrated and the external) goes black after a couple of blinks, like if the system tries to do something, the laptop is still powered on though.

No combination keys responds and I have to disconnect power to poweroff the laptop.

Can you please advise?

Thanks in advance.

See Howto/NVIDIA - RPM Fusion

I’m having the same issue, which I documented here.

Here are my driver versions (sorted):

kmod-nvidia-470.63.01-1.fc33.x86_64
kmod-nvidia-5.13.12-100.fc33.x86_64-470.63.01-1.fc33.x86_64
kmod-nvidia-5.13.7-100.fc33.x86_64-470.57.02-1.fc33.x86_64
kmod-nvidia-5.13.9-100.fc33.x86_64-470.63.01-1.fc33.x86_64
nvidia-modprobe-470.63.01-1.fc33.x86_64
nvidia-persistenced-470.63.01-1.fc33.x86_64
nvidia-settings-470.63.01-1.fc33.x86_64
xorg-x11-drv-nvidia-470.63.01-1.fc33.x86_64
xorg-x11-drv-nvidia-cuda-470.63.01-1.fc33.x86_64
xorg-x11-drv-nvidia-cuda-libs-470.63.01-1.fc33.i686
xorg-x11-drv-nvidia-cuda-libs-470.63.01-1.fc33.x86_64
xorg-x11-drv-nvidia-kmodsrc-470.63.01-1.fc33.x86_64
xorg-x11-drv-nvidia-libs-470.63.01-1.fc33.i686
xorg-x11-drv-nvidia-libs-470.63.01-1.fc33.x86_64

I implemented the following and rebooted my laptop, but when I close and re-open the lid, the laptop does suspend and resume, but the screen doesn’t recover. You can see the screen backlight, but nothing actually renders (so I have to reboot):

root# systemctl enable nvidia-suspend.service
root# systemctl enable nvidia-resume.service
root# systemctl enable nvidia-hibernate.service

root# cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
blacklist nouveau
options nouveau modeset=0 NVreg_TemporaryFilePath=/var/tmp

Hi everyone,

Thank you for the prompt response.

I spent lot of time making configuration changes but without success.

I tried to uninstall xorg nvidia and nouveau drivers (last one works really bad) and keep working with andgpu drivers, but AMD integrated graphics doesn’t recognize an external monitor.

I had to stop gdm service, blacklist nouveau and amdgpu, then I tried to modify grub config and generate a new grub confi file with grub-mkconfig. Also I tried to gnerate a new initramfs with dracut. Nothing worked at all.

Finally I had to reinstall Fedora in my OS mockup, and install from scratch xorg x11 nvidia and nvidia-cuda drivers. If you install nvidia drivers from rpm fussion repo, the script automatically blacklist nouveau (thankfully!)

I couldn`t find xorg-x11-drv-nvidia-power package nor rpm fussion free neither non free. Anyway, enabling nvidia suspend|resume services works fine though.

Thank you @leigh123linux, the solution to the bug works fine for me, and thanks to @nmvega for the contribution.

I hope nvidia will solve this issue in the next package update because I am still having scrren tearing issues with my nvidia GTX 1650.

Please nvidia don’t forget Linux and take care of Linux users/admins/devops as we are many many users around the globe and we deserve the same experience as windows users.

Hi @oz0no:

Thank you for your feedback.

Can you share your /etc/modprobe.d/nvidia.conf file (or whatever file you have nvidia options in?

Also, just to clarify, in the end (net-net) all you did way basically the following, and things worked again:

root# systemctl enable nvidia-suspend.service
root# systemctl enable nvidia-resume.service

Sadly, this solution doesn’t work for me on two different laptop models (with different nVidia cards).

H @nmvega,

The only config file I found is /usr/share/X11/xorg.conf.d/nvidia.conf with the following content:

#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section “OutputClass”
Identifier “nvidia”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
Option “SLI” “Auto”
Option “BaseMosaic” “on”
EndSection

Section “ServerLayout”
Identifier “layout”
Option “AllowNVIDIAGPUScreens”
EndSection

And the answer to the question is yes. After a Fedora Linux fresh install, I typed:

$ sudo yum -y install xorg-x11-drv-nvidia xorg-x11-drv-nvidia-cuda
$ sudo systemctl enable nvidia-{suspend,resume}
$ systemctl reboot

Then:

$ systemctl suspend

and the laptop enters in suspended mode. After that I push any key and the device resumes properly.

Hope this helps.

Hi @oz0no:

Yes, it helps. Sadly, it doesn’t work quite as well for me. Resume is the problem: The backlight of the laptop comes on, but never re-renders the desktop. I actually have to press and hold the power button to hard-reboot the laptop. Bummer. I have one of these hybrid display laptops (nVidia and Intel display cards), but I don’t know that that’s the issue (just mentioning it in case someone else reads this).

What version of Fedora are you running? I’m running Fedora-33.

Thanks again for you inputs!

Maybe that’s the same issue as mine? Kernel 5.6: system freeze when resuming from suspend or hibernate

Hi @thesourcehim - Thank you for bringing your thread to my attention and for the work that you are doing there!

I quickly skimmed the thread from a tiny phone browser (lol), but your issue looks very related to mine and probably even identical to it. I’ll read it more thoroughly when I get a chance, perhaps try some steps you tried and chime in over there.

This all started out of nowhere and I have two different model laptops that are affected by this. Thanks again!

Have the same issue. After enabling nvidia suspend/resume/hibernate service laptop is suspending however can not wake up. I have black screen and unresponsive keyboard, only hard reset is possible.
My card is NVIDIA Corporation GK107GLM [Quadro K1100M] (intel graphics disabled in bios). Everything works when Nvidia driver is disabled.

Os: Fedora 34
Kernel: 5.13.12
Card: NVIDIA Corporation GK107GLM [Quadro K1100M]
Driver: 470.63.01