Problem trying to suspend and hibernate


I am using an Acer Nitro 7 with an NVIDIA GeForce GTX 1650 and Ubuntu 20.04.4 LTS.

The main problem I have is that I can’t use the suspend or hibernate options because the system does not resume.

At boot I get this error:
[FAILED] Failed to start nvidia-powerd service

And when I run “systemctl status nvidia-powerd.service” I get the following:

● nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/lib/systemd/system/nvidia-powerd.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2022-08-06 11:21:20 CST; 1h 16min ago
    Process: 1036 ExecStart=/usr/bin/nvidia-powerd (code=exited, status=1/FAILURE)
   Main PID: 1036 (code=exited, status=1/FAILURE)

ago 06 11:21:19 carlos-Nitro-19 systemd[1]: Starting nvidia-powerd service...
ago 06 11:21:19 carlos-Nitro-19 /usr/bin/nvidia-powerd[1036]: nvidia-powerd version:1.0(build 1)
ago 06 11:21:20 carlos-Nitro-19 /usr/bin/nvidia-powerd[1036]: SBIOS support not found for NVPCF GET_SUPPORTED function
ago 06 11:21:20 carlos-Nitro-19 /usr/bin/nvidia-powerd[1036]: No matching GPU found
ago 06 11:21:20 carlos-Nitro-19 /usr/bin/nvidia-powerd[1036]: Failed to initialize RM Client
ago 06 11:21:20 carlos-Nitro-19 systemd[1]: nvidia-powerd.service: Main process exited, code=exited, status=1/FAILURE
ago 06 11:21:20 carlos-Nitro-19 systemd[1]: nvidia-powerd.service: Failed with result 'exit-code'.
ago 06 11:21:20 carlos-Nitro-19 systemd[1]: Failed to start nvidia-powerd service.

I also upload the nvidia-bug-report.log.gz file if needed.

nvidia-bug-report.log.gz (409.6 KB)

You can ignore (or mask/disable) the nvidia-powerd service, it’s only for rtx3xxx mobile gpus.
There wasn’t any sign of a suspend cycle being stated in the logs.
Please create a new log after trying to suspen.

1 Like

Thanks! The first error at boot stopped showing up. But the suspend option is still not possible.

This is the new log after a failed suspend cycle:

nvidia-bug-report.log.gz (563.2 KB)

Thanks for the help.

There’s still no sign of any suspend cycle in the logs. How did you try to suspend?

Try the commands below.
The commands below will disable Nvidia suspend service, but not break the system suspend service.
After you can enable changing “stop” to “start” and “disable” to “enable” and restart the system.

sudo systemctl stop nvidia-suspend.service
sudo systemctl stop nvidia-hibernate.service
sudo systemctl stop nvidia-resume.service
sudo systemctl disable nvidia-suspend.service
sudo systemctl disable nvidia-hibernate.service
sudo systemctl disable nvidia-resume.service