/usr/bin/nvidia-powerd[1118]: SBIOS support not found for NVPCF GET_SUPPORTED function

Hello. I am using a DELL Precision 5750 laptop for work. Around Jun 13th I started getting error messages in the journal. The OS is fedora 35:

Jul 13 19:17:27 dell5750.eos.ncsu.edu systemd[1]: Starting nvidia-powerd service…
Jul 13 19:17:27 dell5750.eos.ncsu.edu /usr/bin/nvidia-powerd[1118]: nvidia-powerd version:1.0(build 1)
Jul 13 19:17:27 dell5750.eos.ncsu.edu /usr/bin/nvidia-powerd[1118]: SBIOS support not found for NVPCF GET_SUPPORTED function
Jul 13 19:17:27 dell5750.eos.ncsu.edu /usr/bin/nvidia-powerd[1118]: No matching GPU found
Jul 13 19:17:27 dell5750.eos.ncsu.edu /usr/bin/nvidia-powerd[1118]: Failed to initialize RM Client
Jul 13 19:17:27 dell5750.eos.ncsu.edu systemd[1]: nvidia-powerd.service: Main process exited, code=exited, status=1/FAILURE
Jul 13 19:17:27 dell5750.eos.ncsu.edu systemd[1]: nvidia-powerd.service: Failed with result ‘exit-code’.
Jul 13 19:17:27 dell5750.eos.ncsu.edu systemd[1]: Failed to start nvidia-powerd service.

Here is the output from inxi -G

Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
Device-2: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q] driver: nvidia
v: 515.57
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 21.1.4 driver: X:
loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
resolution: 1: 1920x1080~60Hz 2: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.9

Is the graphics chip too old for the nvidia-powerd service? I don’t see way to turn off the nvidia GPU in the BIOS/UEFI and would prefer to run the card in a low or no power state since I don’t use it for gaming. Any ideas?

nvidia-powerd is for dynamic bost, only supported on some notebooks. Just disable and mask.
With Fedora default setup, the nvidia gpu should be in offload mode and runtime pm be used. The current state can be fetched running
cat /sys/bus/pci/devices/0000\:01\:00.0/power/runtime_status
should be ‘suspended’ unless you run something on the nvidia gpu or have an external monitor connected to it.

Thank you for the reply about nvidia-powerd. I have this in /etc/modprobe.d/nvidia.conf

[root@dell5750 ~]# cat /etc/modprobe.d/nvidia.conf

Enable DynamicPwerManagement

Chapter 22. PCI-Express Runtime D3 (RTD3) Power Management

options nvidia NVreg_DynamicPowerManagement=0x02
options nvidia NVreg_PreserveVideoMemoryAllocations=1

The output of this command:

[root@dell5750 ~]# cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status
active

shows the card as active. How can I make it say ‘suspended’ ? It says ‘active’ after a fresh reboot with nothing using the NVIDIA card. glxgears -info says: GL_RENDERER = Mesa Intel(R) UHD Graphics (CML GT2)

Sorry. My earlier post got cut off.

[root@dell5750 ~]# cat /etc/modprobe.d/nvidia.conf
options nvidia NVreg_DynamicPowerManagement=0x02
options nvidia NVreg_PreserveVideoMemoryAllocations=1

Also, I tried disconnecting the external monitor and it still shows as “active” for some reason.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (265.8 KB)

Thank you. Let me know if you need any other information. I ran systemctl mask nvidia-powerd.service and disconnected the external monitor before running /usr/bin/nvidia-bug-report.sh as root.

The hdmi port is connected to the intel igpu, so having a monitor attached to it shouldn’t keep the nvidia gpu from suspending. Furthermore, everything is set up correctly, runtime pm fully supported on your device.
The bad news is, it just doesn’t suspend.
One oddity I noticed is
/sys/bus/pci/devices/0000:01:00.0/power/runtime_usage does not exist
which should be created by the kernel (unless kernel devs renamed it in 5.18 but I couldn’t find anything about it) which might point to some kernel issue.
Also, the nvidia X driver complains about acpid not installed. This shouldn’t have an impact on runtime pm but you never know, please install it and check if that lets the gpu suspend.
In general, please check if you have any monitoring software/gnome plugin installed that polls the nvidia gpu so doesn’t let it sleep.

Thank you so much for your help! It turned put there was a hardware monitor on my desktop. And once I unchecked nvidia it went into suspended. The monitor is called Sensors Applet it MATE if other users experience this.