"API mismatch" error when running the OpenCL executable

$ oclDeviceQuery
Error: API mismatch: the NVIDIA kernel module has version 185.18.14,
but this NVIDIA driver component has version 185.18.08. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.

I am using the OpenCL Conformant release.
Which component do I need to update to match the kernel module?

thanks
-gshi

Never mind. Fixed.

i have this same problem, I’ve tried installing the latest drivers from the website using a kernel from debian unstable. I get the error about 185.18.08 even though i installed the 185.18.14 drivers and kernel module, and nvidia-settings says my driver version is 185.18.14.

why does it think i have 185.18.08? as far as i know i have never installed that on my machine.

panda21,

Our “solution” is downgrading driver version to 185.18.08 and it’s not really a solution.

I think opencl is somehow hard linked to 185.18.08 and any other versions of driver will not work.

Since we need maintain an up-to-date driver and cuda, openCL is not usable in our GPU cluster.

Could any of nvidia guys please look into this?

-gshi

http://forums.nvidia.com/index.php?showtopic=101627

oh i see, thanks. i tried installing 185.18.08 on my desktop but it crashes when i try to start X (185.18.14 works fine…)

looks like i will just have to wait.

is there a way to fix this problem without installing 185.18.08? cuda 2.3 requires 190.xx !!

Indeed - a OpenCL driver that supports CUDA 2.3 would be very useful.