Apparent refresh rate lower than nvidia-settings using 375.66-11 and GTX1070


I am having an issue where the apparent refresh of my display is much lower than what I am setting it to in nvidia-settings. I am setting the refresh rate to 144 Hz (which my monitor is capable of), but the motion is very coarse and the screen is visibly flickery, as if I am looking at a fluorescent light tube. Unscientifically, it looks slower than a regular computer, so less than 60 Hz. These problems strangely do not occur at the login screen, with no flickering and the mouse motions are as smooth as I would expect at 144 Hz.

As mentioned I am using driver 375.66-11 and a single GTX1070, my monitor is an ASUS PG279Q. My distribution is Manjaro Linux using the Budgie desktop environment.

Any ideas about what is going on? I have attached the output.

nvidia-bug-report.log.gz (110 KB)

Does the problem go away if you uncheck the “Allow G-SYNC” checkbox in the OpenGL page of nvidia-settings? If so, we probably need to add an application profile to disable G-SYNC for the desktop compositor that Budgie uses.

Yes that fixes the problem, thanks! I’ll let the Solus people know about this.

Aha, I see the problem. Budgie is based on libmutter, and we already have a rule to disable G-SYNC for Mutter-based compositors, but the match is for “” and the name of the library changed to “”. I’ll relax the check to pick up on this variation.


It seems that Budgie is using now, and the above problem is still present.
Manually disabling G-Sync fixes Budgie, but unfortunately disables it for games as well.

As a temporary workaround, I have put the following command in Budgie/Raven autostart:
nvidia-settings -a AllowGSYNC=0
This seems to disable it for the desktop session only, and not for games.
(Checkbox even stays on in nvidia-settings)

My Solus 3 system contains these two files: