G-SYNC not working on Ubuntu 17.10 + Dell AW3418DW

I recently got a Dell AW3418DW that is set to 120Hz refresh and is showing that the monitor is operating in G-SYNC mode in the OSD info but, when I play, I don’t see any G-SYNC indicator, even if the entry inside the NVIDIA settings is checked: https://i.imgur.com/S7Bo0AE.png

I tried with CS:GO, TF2, DiRT Rally and Tropico 5. For the source games I’ve added “+gl_swaptear 0” as launch option like it was suggested in a thread on this forum, but nothing has changed.

The AW3418DW is the only monitor connected. I have installed mutter version 3.26.2-0ubuntu0.1 that should fix this bug.

I tried with both NVIDIA driver version 387.34 and 390.25.

nvidia-bug-report.log.gz attached and also available here.

System info:

System:    Host: x87-deluxe Kernel: 4.13.0-32-generic x86_64 bits: 64 Desktop: Gnome 3.26.2 Distro: Ubuntu 17.10
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: Z87-DELUXE v: Rev 1.xx serial: N/A
           BIOS: American Megatrends v: 2103 date: 08/15/2014
CPU:       Quad core Intel Core i7-4770K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 3900 MHz 1: 3499 MHz 2: 3499 MHz 3: 3499 MHz 4: 3499 MHz 5: 3499 MHz 6: 3499 MHz
           7: 3499 MHz 8: 3499 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1080]
           Display Server: x11 (X.Org 1.19.5 ) driver: nvidia Resolution: 3440x1440@120.00hz
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 version: 4.5.0 NVIDIA 387.34

I just tried with Xfce4 and I get the same exact result as Gnome Shell (no G-SYNC indicator).
nvidia-bug-report.log.gz (151 KB)

bump, still no G-SYNC :(

Don’t know if gsync works with forcecompositionpipeline, maybe disable that and check.

Hey thanks! This actually worked! What is the purpose of forcecompositionpipeline? Am I loosing something not having it enabled? I am currently not seeing any tearing with forcecompositionpipeline off.

I think downside is tearing on desktop, as there, gsync is off.