G-Sync not working and enable-option not visible, despite compatible hardware

I believe that my setup (GTX 1070, G-Sync tag on my monitor; more details further down) should support G-Sync, but it does not work (according to the visual indicators from the nvidia-settings). The most common suggestion I have found online was to enable an option in nvidia-settings:

X Server Display Configuration → Advanded → Enable “Allow G-SYNC on monitor not validated as G-SYNC Compatible”

However, this option is not visible for me.


  • Fedora 39 Workstation
  • Kernel 6.8.4-200.fc39.x86_64
  • Gnome 45.5 with X11
  • Monitor AW3418DW, connected via DP
  • GTX 1070
  • nvidia-bug-report.log.gz (599.5 KB)

Things I have tried

  • Not using any xorg.conf (which is the Fedora default, if I am not mistaken)
  • Using xorg.conf created by nvidia-settings (xorg.conf.txt (1.6 KB))
  • manually running the command:

sudo nvidia-settings --assign CurrentMetaMode=“DP-2: 3440x1440_120 { AllowGSYNCCompatible=On }”

Despite being an enthusiastic linux user, I am a rookie when it comes to the terminal. So if there is anything I can try or any report I can provide, I will be very glad to do so if you can provide me with the specific commands to run.

Thanks in advance!

Pushing the topic, as the issue still exists.

Hi mate,
As far as I know the only option to enable it is in the OpenGL submenu:

EDIT: Apologies - I have misread your post - ignore me.
I assume you’ve ticked the G-sync option pictured above and checked the visual indicator and it’s still not working. In which case I’m not sure as I haven’t encountered that problem myself.

Hi Xeauron and thanks for your message.

Your assumption is correct that I have already enabled this setting:

I always get the “NORMAL” indicator in the top right corner. No matter, if it’s a windowed application or a fullscreen app (e.g. steam game).

Anything else I can try or check?

Looks like you’ve enabled the settings in the correct location. I’m not sure on this one, far as I can tell you’re not on a laptop, you’re not using HDMI (which would be a problem with an older HDMI standard port). In fact it looks like near the same model monitor I have.

That’s a weird one.

What would I do…easiest first, I’d try a different cable since you seem to have the software set up correctly to eliminate that being a possibility. Be sure to disconnect any other monitors.
Does G-sync work in Windows on that monitor? If it does, forget the cable…

Another option would be to try a live USB of another distro (I would pick an Arch based distro to test personally) with the proprietary driver enabled and see if I could get it going there to eliminate the desktop environment being the cause. I think Manjaro does a live USB image with Nvidia drivers as an option, then run glxgears and see if the indicator shows GSYNC.

I don’t know enough about the driver to make any suggestions regarding digging around in the terminal, you could maybe check the journal “journalctl -b -1” to check last boot - maybe grep for Nvidia “journalctl -b -1 | grep Nvidia” and see if there are any errors that jump out.

I have the following set in my kernel parameters as well for what it’s worth:
*Note: this may be a red herring!
nvidia_drm.modeset=1 nvidia_drm.fbdev=1

You’d have to check the fedora documentation on how to enable kernel parameters if you’ve not done already:

I’m on Arch Linux with systemd boot (not grub, I’m not a fan of grub). This may be relevant:

I’ve not used fedora since about 2003 so I’d have to do a lot of reading up before I could help there.

Beyond that I’m not sure - but I’d definitely try a new, clean (default) environment in which to test. If it works there then the issue is with the fedora install, and re-installing drivers and resetting configs would be in order.

Thanks for your help @Xeauron!
The solution was indeed that simple: I disconnected my second monitor, bought and connected a new DP cable and the G-SYNC status did indeed activacte as intended.

Hey, good stuff!
Glad to hear you got it sorted.

Happy gaming :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.