GSYNC available but no option to enable in nvidia-settings (Arch Linux, X11)

As the attached images show, my GSYNC-supported laptop (Razer Blade Advanced 15" Early 2021, RTX 3070 Mobile) does not have the option to enable GSYNC under “OpenGL Settings” in nvidia-settings. For reference, my system is:

  • Arch Linux amd64 (UKI enabled)
  • Linux 6.8.1-arch1-1
  • GNOME 46.0 (Xorg)
  • nvidia 550.67-1

I have the following module parameters set:

options nvidia_drm fbdev=1
options nvidia_drm modeset=1
options nvidia NVreg_PreserveVideoMemoryAllocations=1
blacklist nouveau

Image of GSYNC being available but not enabled:
Image of there being no option to enable GSYNC being available:

I should add that I am dualbooting Windows 10 and GSYNC works as expected on it. I would greatly appreciate any help or suggestions. Let me know if there is any other information needed.

nvidia-bug-report.log.gz (707.9 KB)

Maybe your issue is related to mine. I’m attaching the link for reference.

Gsync screen of the Alienware M18 R2 is not detected - Graphics / Linux / Linux - NVIDIA Developer Forums

1 Like

I have a similar issue.
DP-4 - (Iiyama PL3466WQ): G-SYNC Mode Available: G-SYNC Unvalidated, G-SYNC Mode Enabled: Yes
Using a Club3D VESA certified displayport 1.4 “8K” cable.
GSYNC/COMPATIBLE ENABLE and the GSYNC VISUAL INDICATOR checkboxes are not available.
I tried manually adding he option for the visual indicator in the config file at one point but it removed it. I think there was an error stating that it wasn’t available or something.

G-SYNC had previously been working including the visual indicator on the top right. But only briefly as I had just gotten new hardware and was playing around with settings and was upgrading packages as well. I tried downgrading nvidia-drivers, but that didn’t fix it.

Fresh install of “binary handbook vanilla open-rc” Gentoo with Plasma 5 and proprietary nvidia-drivers.

  • Linux 6.6.21-gentoo-dist
  • KDE Plasma 5.27.11
  • nvidia 550.67 (I -think- I tried reverting to 470.239.06; no change).
I've tried both modeset=1 and modeset=0
options nvidia NVreg_PreserveVideoMemoryAllocations=0
blacklist nouveau

options nvidia_drm fbdev=1 is commented out. I probably also tried flipping it.

xorg.conf Config generated with nvidia-xconfig (and AllowGSYNCCompatible=On added with nvidia-settings makes no difference).
HorizSync seems off though, as generated it’s at 222.0 - 222.0, but the specs of my monitor state 30-160. Changing it, and using EDID ignoring options doesn’t have an effect.
Disabling the compositor through setting early kwin variables (which does indeed disable compositing) also doesn’t have an effect.
vrr works (somewhat?) in Wayland.

Many-boot and 2xRTX 3000 series (but again, at one point it did work with this exact same hardware).