G-Sync Mobile support? (970M)

Hi guys.

Is there any information on whether Mobile G-Sync is supported or on the way?

I’ve got a Clevo P750DM-G, 1080p@60hz G-Sync eDP panel, 970M, Mint 17.3 running the latest 4.5 Kernel and 364.12 drivers (that was some mucking around…).

No G-Sync option in Nvidia Settings.

Similarly, I noticed the Windows drivers lack G-Sync support for this laptop in the latest iteration (364.72) and I had to roll back to 362.00 in Win10.

I’m guessing there’s a list of G-Sync enabled BIOS cookies that the driver gets baked in and this laptop seems to miss out on every other release for some stupid reason (I’m betting on human error)?

Did you test with 361 drivers on Linux? Please attach nvidia bug report.

I too have the same problem with a GTX970M, G-sync works fine on windows but no mobile g-sync on linux with the latest 364 drivers, also tried older drivers.

Where is this nvidia bug report typically stored?

I know how to get the report and will try and get it uploaded tonight

I have attached the bug report, can’t wait for a reply

Thank you so far
nvidia-bug-report.log (1.17 MB)

It would be nice to get an update on this matter.

Could anyone of the NVIDIA team at least let us know that they are reading through the nvidia-bug-report.log file?

Thank you in advance.

The 364 driver is not stable. So much so that it doesn’t exist anymore. It’s now 367.

I would use 361.45.

add-apt-repository ppa:graphics-drivers/ppa
apt-get update

Then choose 361.45 or 352.79(old faithful) from your Menu/Administration/Driver Manager. It’ll be listed as ‘open-source’ even though it ain’t.

If that don’t work, then you’re hosed. Btw, don’t upgrade to the 4.6 kernel. It don’t work so hot. 4.5.5 is the latest kernel that works(but you probably already knew that).

Bump, Please can I have some sort of reply of the NVIDIA team?

Hi,

I’m having the same issue with a Clevo P751DM-G (G-Sync capable) and a GTX980M.
I tried both 361.45 and 367.18 drivers, but couldn’t get the G-Sync option available.

nvidia-bug-report.log (1.18 MB)

We first need to check if the Notebook display is connected to NVIDAI discrete GPU or Intel iGPU.
We can utilise the features of NVIIDA GPU only if the display is connected to dGPU. If the Laptop screen goes to iGPU then G-Sync won’t be available from NVIDIA.

Of course, it is. This laptop model has only NVIDIA dGPU. The iGPU is disabled by the BIOS and can’t be enabled (there is no Optimus).

And it works well on Windows 10 (tested today).

I filled a bug on http://www.nvidia.com/page/support.html but the only response I got is currently that mobile G-Sync is not supported on Linux, and support team has no information on future updates about it…

But since NVIDIA seems to still have some VSync issues with Optimus on Linux, and given that it has probably a higher priority than mobile G-Sync (there’s a lot more users of optimus laptops than high-end machines like this one), I’m afraid we’ll have to wait for some time before seeing this feature supported on Linux.

Of course, we’d like at least some official information about mobile G-Sync status on Linux.

It’s supposed to work, so the fact that it doesn’t is a bug. I’ll try to track down one of these laptops so I can find out what’s going wrong.

Any update on this?

I have an ASUS Strix G502VY - 980M 4GB (no optimus, and G-Sync working under Windows 10).

I have tested this with:

debian/sid - nvidia 352 from repo, and 367 from https://anonscm.debian.org/viewvc/pkg-nvidia/packages/nvidia-graphics-drivers/branches/367/

ubuntu Xenial 16.04 - nvidia 361 from repo, and 367 from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

No dice, anywhere - The G-Sync settings simply do not appear in nvidia-settings.

Many Thanks

Same issue here. I have an Aorus X5 with dual GeForce GTX 965M’s (though the second one is sadly mostly useless in Linux without SLI support).

G-Sync is working on Windows 10, however the G-Sync setting will not even display under Linux.

I have tested on Arch Linux and Ubuntu Xenial 16.04 with Nvidia 367.35 (from the same repo as D_Swarm above).
MGwyPuX.png

I have got an PCSPECIALIST OCTANE PRO II with GTX970M graphics. No optimus on my laptop and can also confirm that g-sync works very well on Windows.

I would love to hear an update on this.

If you need any more info please let me know

Still no mobile G-Sync support with drivers 370.23.

Any progress on this side?

Aaron, could you manage to get such a laptop to see what’s going on?

Out of curiosity, I am only able to change the screen resolution through nvidia-settings and it is (scaled).

I can’t change my resolution through the linux display/monitor manager. xrandr won’t let me add any custom resolutions either.

Can anyone confirm the same issue? I was wondering whether it is linked to it not being able to use the display EDID properly or maybe that it uses a display port for the internal screen.

Will keep you updated if I find anything bigger.

I still haven’t tracked down a laptop that exhibits this problem. For reference the tracking bug number is 1802281.

Mr_Pixels, what you’re describing is expected. xrandr only lists modes that are actually supported by the display. Since it’s an internal laptop panel, there’s typically only one supported mode. You can display other desktop sizes and scale or letterbox them to the display mode using various combinations of the --scale / --scale-from options and the Border property, or you can do the same thing using the ViewPortIn and ViewPortOut MetaMode attributes. You can configure those from nvidia-settings advanced display configuration page. The basic display configuration page lists those scaled resolutions as a convenience – they’re really just easy ways of setting ViewPortIn to something smaller than ViewPortOut.

The fact that your display/monitor manager doesn’t provide a way of configuring scaled modes is a limitation in that software.

Thanks for that information.

Hope to hear from you soon about any updates on the G-SYNC matter.

@aplattner: Just making sure this thread doesn’t get old. Any news on the g-sync matter?

No news, sorry.

Just figured I’d add I have the same issue on the new Clevo P650RP6-G laptop with a 1060 GPU in discrete mode. No G-Sync option in nvidia-settings. I hope nvidia adds support for this soon!