NVIDIA 470.74 Breaks Gsync (Compatible) Support (Monitor Modulates between 0 or 144hz and Flickers black)

Good Afternoon,

I was so excited to see the release of the 470.74 driver release as I have not been able to get past the memory leak on dx12 games with proton. However, with the new update it appears gsync is no longer working unless I revert back to a previous driver version.

I am currently using an LG-27gl83a-b which had worked previously on ever other driver version

currently on linux kernel 5.14.6, this occurs in every game.

Disabling gsync in nvidia-settings allows flicker to stop, however, now gsync is not active.

Edit: I am on a 3080

I had made a post on reddit and multiple other people were having a similar issue. However, a trend I am noticing is it is the gsync compatible and freesync displays. One reddit user has a gsync only display and said they were having no issues. Other than that I don’t know of other users that are not having the issue.

Can confirm that if I enable G-sync it won’t even let me boot it straight up gives black screen and it has worked on every other previous driver just fine. RTX 3070 paired with AOC C24G1

1 Like

I have the same issue.

Before 470.74 I was getting random black screens on games loading screens, that would come back after 3 seconds. After installing 470.74 I can’t even enable G-Sync anymore or the screen never actually renders anything when I enter a game.

The black screen issue is gone if I disable G-Sync, which leads me to believe the previous issue was also G-Sync related.

edit - I’m on a 1050Ti, and my monitor is a Dell 2721DGF. Kernel 5.14.6


Same issue, RTX 2060 with AOC C24G1

Other than with games, with G-Sync enabled SDDM will show a black screen, while still working properly and logging you in after entering the password

1 Like

I have the exact same symptoms here, using a Samsung Odyssey G7 monitor and an RTX 2080. With previous drivers I was getting 3 second black screens any time a frame would stutter for too long (shader compilation or long pauses during load screens), with the new driver as soon as a game enables gsync the display turns black. I can still switch to TTYs and recover by killing the game from there.

1 Like

Yea I believe it is because the driver is not properly communicating to the monitor to lower its refresh rate. If you have the option to see the current refresh rate of the monitor (at least in my case) it switches between 144 and 0, but nowhere in between. If the game is capable of being 144 it will display at 144 and then flicker black when it tries to lower the refresh rate as it switches straight to 0. For example, if the game gets any less than 144 hz it will not display with the current driver.

I also confirm no g-sync, although no black screens over here. LG C1 confirms it is not receving any type of G-sync / vrr signal.

3090 + LG C1

1 Like

I wonder if there is a fix we can do on our end or our repo’s end, or if we will just have to wait and pray for a fast fix

1 Like

Thanks for reporting this. We’re tracking it with bug number 3382581.


This looks similar to a problem I’m experiencing on Manjaro with FFXIV where, when the game runs, after a short amount of time, my LG CX TV will just go black (I can sometimes hear very short scraps of sound go through my speakers (HDMI Audio) but that’s it. Strangely enough, if I ALT+TAB out of the game, or put the game in Windowed mode, it works fine.

(Note: I usually run the game in Windowed Fullscreen)

Pardon my newbishness, even if I lightly dabbled in Linux for years, I still consider myself a newbie.

EDIT: This problem is new as-of 470.74 for me

Manjaro does not have this driver on the stable branch. They purposely blocked this driver from reaching stable due to the issues.

can confirm on arch. it breaks sddm and fullscreen games/applications that will use gsync with nvidia 470.74. as a workaround I downgraded my nvidia packages to 470.63.01 and the gsync issue is fixed. obviously this isn’t a long term fix, but I’ll keep my nvidia package on hold until this issue is resolved. to downgrade i used the archlinux archive to download the nvidia-dkms package then downgraded every nvidia package to use 470.63.01.

os: Arch Linux x86_64
kernel: 5.14.6-arch1-1
driver: 470.74
gpu: rtx 2070 super
monitor: AOC 24G2W1G4

Fair enough but if i gotta choose between my computer kernel panicking when i open my tv to this, ill choose this lol

I had this happen to me today. For a moment I thought that video card was defective.

Games that triggered the problem are Blizzard titles: Diablo II Resurrected, WoW and even the modernized Stracraft

Tried Doom Eternal on Steam and that worked fine for the short time I tested it. Granted I was seeking to validate that my video card was still working correctly…

GPU: GTX 1070
Monitor: LG 27GL650F-B

Same problem here. First noticed it running Guild Wars 2, and reproduced with a native game afterwards (Metro Last Light Redux).
RTX 2080 (VBIOS, Samsung C27HG7x (firmware 1025.0) over DP

Affected by this as well. Full screen games will now display a black screen.

I was able to reproduce the problem on video with my TV’s HDMI diagnostics enabled. Hopefully it helps in fixing it:

@aplattner do you have any updates on this issue?

This bug has been fixed internally and will be resolved in upcoming releases.


Thanks for the reply! Is there an estimate when the next 470 driver release will be?