NVIDIA 470.74 Breaks Gsync (Compatible) Support (Monitor Modulates between 0 or 144hz and Flickers black)

Bump. I’m also affected by this bug and am interested in hearing any estimates for a new driver so that I can get my system running normally again

1 Like

Also affected here. Essentially everything using a G-Sync compatible display becomes unbootable when using this driver. We have to chroot in using a liveUSB and disable the display manager and either disable G-Sync or revert to 470.63. I would call this a showstopper bug as people won’t even know why the systems are unbootable unless they SSH in or livecd/chroot.

We are advising all clients to AVOID this driver release and are hard blocking it across our networks.

The new 470.62.05 vulkan dev drivers released yesterday are also impacted by this.

1 Like

I have a GTX 1070 and gsync is broken on the Dell S2721DGF, Am getting an RTX 3070 soon, I hope they fix this cause its an expensive and well known monitor. Hardware Unboxed reviewed and recommended.

Probably a related issue: [470.74] [REGRESSION] Full screen videos in Google Chrome freeze the system after suspend/resume - #2 by birdie

Hi, any update on this one?

Do we know when you’ll gonna release a new drivers’ version which addresses this issue?
Is it going to be a minor or major driver release?

https://www.nvidia.com/download/driverResults.aspx/181159/en-us

Issue should be fixed there, and interestingly Kepler is still supported.

1 Like

@danielsuarezcolon Likely just forgot to update the text there, in the driver files everything related to Kepler was removed.

I can confirm that Gsync compatible works for me on driver 495

1 Like

Indeed it was a mistake, seems it was fixed now

Did you just use nvidia-beta-dkms from aur? Or how did you install

I used the nvidia-all pkgbuild, it’s not from the AUR

Can anyone confirm whether this has been fixed in version 470.82.00 as well?

Hi Staudi,
Fix is integrated in driver 470.82.00.
Please verify once and share test results.

Thanks for the response!
Unfortunately I don’t own hardware affected by this myself, but will package this version for the Solus repository. Maybe I can get someone to test it beforehand (but I think all bug reports for this issue came from people on the Stable repository, so it will probably take at least until Friday when the Unstable packages are synced to that repo)

Hi Amrtis,

I was running 495.44 and the problem had been fixed for me on Ubuntu 21.04 and kernel 5.14.1. I then upgraded to Ubuntu 21.10. After doing so, sometime a few days later, suddenly the bug returned. I tried to downgrade to 460, however, this installed 470.82. It’s still flashing around for me on kernel 5.14.1 on X11 on Ubuntu 21.10.

To be fair, I’ve installed these via the Ubuntu repositories, not the nvidia driver installer. I’m wondering if X11 switched to using GBM instead of EGL Streams native mode for nvidia, and this bug as returned?

Do you recommend that I try the nvidia installer for 495.44 instead rather than from the repo? Can you advise on supported kernel versions for this driver? I upgraded to a newer kernel because of support for my keyboard, but I could downgrade if required.

X Version number: 11.0
X.Org version: 1.20.13
gnome-shell: 40.5-1ubuntu2
Linux 5.14.1-051401-generic

Edit: Tried purging and install drivers again in kernel Linux 5.13.0-21-generic, going out of sync during change of display; such as loading a game or a graphics accelerated program.

I’ve reported this bug here for Ubuntu users, please click “Affects me” at the top of the page to get this bumped up in priority.

Thanks

I’ve fixed my issues in Ubuntu 21.10, for any linux users experiencing a signal loss momentarily 1~2 seconds during changing of GPU accelerated program with NVDIIA with G-SYNC and Flipping enabled, in my case the issue was related to my user profile. I created a new user to test and could not reproduce the issue.

I had tried the following drivers, but the issue persisted:
470.86, 495.44, 495.46, 510.39.01.

I had also tried resetting my NVIDIA settings in my profile by removeing ~/.nv and .cache/nvidia.

My guess is that something happened during distribution upgrade with dconf or in my .config folder that caused this issue. To resolve this problem I performed the following steps:

  1. Ensured I had set a root account password
  2. Backed up critical bits of software/configuration
  3. Logout to login screen
  4. Change to terminal [Ctrl+Alt+F5]
  5. Login as root
  6. mv /home/username /home/username.old
  7. cp -rT /etc/skel /home/username
  8. chmod username:username /home/username
  9. exit
  10. [Ctrl+Alt+F1] to return to GDM login screen
  11. Login as user
  12. Restore files, settings and configuration from /home/username.old & /home/username.old/.config as required

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.