G-Sync + DSC 4K 144 Hertz black video output while gaming

Hello, I have just bought a 4K 144 Hertz screen.

Trying to play at 144 Hertz (DSC activated in the monitor) + G-Sync results in black video output.
No issues using the desktop (maybe because it stays all the time at 144 Hertz? who knows).

Putting the monitor at 95 Hertz with DSC fixes it (it is the second available frequency with it enabled).
Putting it at 120 Hertz without DSC fixes it.

I have a RTX 2060 Super (2 x Display Port 1.4a 2 x HDMI 2.0) and driver 535.104.05.
The monitor is a brand new LG UltraGear GR93U 27" 4K 144 Hertz.

Tested with a certified DP 1.4 cable and the cable included with the monitor with the same result.

EDIT: I’ll share a log, I have started it before launching a game with the issue, I hope it is good.
nvidia-bug-report.log.gz (5.2 MB)
And a video where I show to you the issue (I’m sorry for the mic, my phone has some issue too!)

You’ll get problems soon. I promise you that. I believe it’s related to the driver bug where peoples screens are flickering at high refresh rates. Hopefully the bug they’ve triaged is the same… because this is goddamn annoying.

Up! I have posted both a log and a video, would be nice to have someone at NVIDIA saying that they have seen this post at least.

@cippo1995
Thanks for writing to us, I have filed a bug 4303984 internally for tracking purpose.
Shall try for local repro and if needed any other information, will get back to you.
Do you know by any chance last passing driver where it worked fine.

Thank you very much!

I have just bought (one week ago) this 4K 144 Hertz monitor so I have tested it only with driver 535.104.05 (I’ll install 535.113.01 soon), so I don’t know if it was fine with some previous driver.

With G-Sync enabled it is fine without DSC at 120 Hertz or with DSC at 95 Hertz.
With G-Sync disabled it works fine at 144 Hertz.

@cippo1995

The symptoms are a bit different, but to confirm if this is the same issue that @dvsaleios mentions, could you try loading nvidia-modeset with ‘disable_vrr_mclk_switch=1’ and see if you still have problems?

I’m not familiar with this modesetting, so please tell me if I have done something wrong, or what is the “good way”.

I have tried to write it on the kernel parameters like this:
GRUB_CMDLINE_LINUX="preempt=full rd.driver.blacklist=nouveau nvidia_drm.modeset=1 disable_vrr_mclk_switch=1"

Rebuilding GRUB etc. without fixing it.

I have then tried to do a /modprobe.d/modprobe.conf file with this:
options nvidia-modeset disable_vrr_mclk_switch=1

Without fixing it.

@cippo1995
Please try below steps and share test results as requested, thanks in advance.

rmmod nvidia-drm nvidia-modeset
modprobe nvidia-modeset disable_vrr_mclk_switch=1

Terminal results:
(ins)[cippo95@fedora:~]$ rmmod nvidia-drm nvidia-modeset
rmmod: ERROR: Module nvidia_drm is in use
rmmod: ERROR: Module nvidia_modeset is in use by: nvidia_drm
(ins)[cippo95@fedora:~]$ modprobe nvidia-modeset disable_vrr_mclk_switch=1
(Latest command didn’t complain)

Games are still doing the same as in the video with said 4K+144Hertz+DSC+G-Sync settings.

That sequence wouldn’t have successfully set ‘disable_vrr_mclk_switch=1’ because the kernel module never unloaded. The last command didn’t complain because nvidia-modeset was already loaded, but the option still wouldn’t have taken effect. All nvidia-drm/NVKMS clients such as X must be stopped before attempting to unload the kernel module. Alternatively (for Fedora), configure /etc/modprobe.d/nvidia.conf with ‘options nvidia-modeset disable_vrr_mclk_switch=1’, run ‘sudo dracut --regenerate-all’, then reboot.

Hi, I’m on Fedora 37 so I have made the nvidia.conf file and sudo dracut --regenerate-all --force (force was needed).

Nothing has changed.

I am also getting this issue with my Nvidia 3090 + LG C2 42inch when using the 545.23.06 drivers. Flickering happens at both 100Hz and 120Hz when VRR is enabled. I’ve already tried the disable_vrr_mclk_switch=1 option and it didn’t work. Here’s my modprobe.d config:

options nvidia_drm modeset=1
options nvidia NVreg_PreserveVideoMemoryAllocations=1
options nvidia-modeset disable_vrr_mclk_switch=1

One thing I noticed was that before the 545 drivers, the TV would report a max frame rate of 119Hz, but now its reporting either 121 or 122.

I get hold of same exact display LG 32GR93U, enabled DSC 1.4, GSYNC and change resolution to 3840 x 2160 with refresh rate as 144 Hz.
Installed Control Game via steam on HP system but did not observe black screen after launching it multiple times.

HP OMEN by HP 25L Gaming Desktop GT15-0xxx + Ubuntu 22.04.1 LTS + NVIDIA GeForce RTX 3080 + Driver 535.86.05 + LG 32GR93U with resolution 3840 x 2160 and refresh rate as 144 Hz
HP OMEN by HP 25L Gaming Desktop GT15-0xxx + Ubuntu 22.04.1 LTS + NVIDIA GeForce GTX 1650 Super + Driver 535.86.05 + LG 32GR93U with resolution 3840 x 2160 and refresh rate as 144 Hz

Could you please check once if you are still seeing the same issue with 545 released drivers as well.
Meanwhile, I will look for system B450 GAMING PLUS MAX (MS-7B86) and GPU NVIDIA GeForce RTX 2060 SUPER internally to match exact hardware in case if its dependent on hardware.

Hello, thank you very much!

I have the 27 inch version of the monitor, but I also think that it should be very close in behaviour.

I have tested it also with the new drivers some day ago with the same issue.

When I find some time to do so I will try to replicate the issue with a clean install of Fedora.
If nothing changes I will report here and probably try with a clean install of Ubuntu.

I will use a spare SSD and try to replicate with VRR test (any application using VRR causes the issue).

PS: Isn’t 535.86.05 driver a little too old? maybe it is an issue appeared after it.
If it is the current default one for Ubuntu maybe I will test it when I try it.

Out of curiosity I have tested with latest Ubuntu LTS 22.04.03.
It had NVIDIA driver 535.129.03 by default.

Same issue, I link a video if you want to see.

So even on a fresh install and different distro the issue is still there.
I have tested the 525.x driver that Ubuntu had in his repo but it was a driver without DSC capability, so no luck.

At this point I think that a test with a fresh Fedora install is no use.

Maybe I can try to install Windows and see if it is a issue there, it should help to understand if it is indeed a bug on the Linux side or some hardware issue with this monitor.

I have tested with Windows 11:

  • With latest driver 546.17 the issue is solved (it black screens 2 seconds while opening or closing the VRR test, but it works after that).
  • With driver 456.71, the one Windows install by itself, I have the same issue as in Linux, so I guess that it is something that was fixed also on the Windows driver after some time.

I have made videos about it, but I don’t think that they are necessary, if you want them I will upload them on YouTube and share them editing this post (or maybe I will do it later myself, now I don’t have time).

I am finally able to reproduce issue locally, thanks for being patient.
This will help us now to debug issue.
Thanks again, will keep you updated.

Thanks to you for the update!
Now I know that it isn’t something only on my end.

I’m testing beta driver 550.40.07 and it seems that the issue is fixed!

1 Like

Thanks @cippo1995 for sharing the feedback.