Auto login option didn't show on first boot

Well, I read on many of the posts here that on the first boot, u will be able to see an auto login option, so i flashed new my sd card and did the first boot and set it up on headless mode, but i didn’t get an option for auto login in the configuration setup…

My aim is to run a python program as soon as I plug power to jetson…so for that I need to auto login in my user account and then configure the program to automatically run on login…I’ll do the latter by this…

I read on many posts that its easier to set the auto login option on the first boot and it works.
So I need a way to auto login as soon as the power is plugged in, so that I can achieve my task of running my program as soon as I plug in the power…
Help me out here please. Thanks

This is what I did to auto login. I’m also trying to start a script at first boot with systemd but I’ve been having issues. I’m not sure if this is the best way to auto login but it does work for me.

In landing page at boot-up (when prompted to sign-in), click icon with “paper and wrench” at top-right corner > click “Unity” > login > click “Power” button at top-right corner > click “System Settings” > click “User Accounts” > click “unlock” button at top-right of window > input password > click button “Automatic Login” to “ON” > exit out > click “Power” button > logout > click “paper and wrench” icon > click “LXDE” > login > reboot

hey @Anthony_G72 …I’m using jetson on headless mode…Can you please recommend a way through that

Unfortunately I don’t have any experience with headless mode.

What interface do you want to “auto-login” if it is headless mode?

hey @WayneWWW . I want to login to my user account…

Yes, of course you want to do is login. But I mean which interface is that? I can login account from monitor, from ssh, from serial console (uart), from serial console (usb). Which one do you want to use?

And how did your first configuration look like ? Was that a headless case or you used a monitor?

Well I use ssh to login so yes ssh…

I used headless mode in the first setup

Then what you are referring to will not work…

What @Anthony_G72 is telling is the auto login into desktop. The auto-login in first boot up configuration is also for desktop.

For autologin through the ssh, maybe using google search will give you more result.

Okay @WayneWWW , but my real problem is:

So is there a solution for that?

Setup up a systemd service may help. This has nothing to do with autologin.

Also, systemd is provided by linux, so you can search more resources.

And actually, I managed to achieve that (partially) but there is this issue…

Can u take a look and tell me if u can help me out?