NVIDIA Jetson Nano 2GB Auto Login doesn't work

Hi,

I have installed the OS in the 2GB version of Jetson Nano.
If I select Auto login during the first installation, the auto login works without any issue.

But if we don’t choose while installing and later if we have to configure it, it won’t work.
I tried below steps and none of them works,

  1. Under User & Preference set Don’t ask for password on login to true --> In this case on boot the Log In page gets displays but doesn’t need to enter password, on click on login button without password it loads the desktop.
  2. Edited /etc/gdm3/custom.conf to set AutomaticLoginEnable=true --> Doesn’t work
  3. Along with 1st option above, Installed dconf editor and edited org->gnome->desktop->lockdown->disable-lock-screen = ON

Same problem here. With the settings 1 and 2 above I use as a workaround keyboard just to press enter to login and then I unplug it and connect using VNC. Quite anoying.

Let us check. Thanks for report.

hi just a friendly follow up. My jetson 2gb boots up headless is it possible to get it autologin at boot through cli? My reverse tunnel service wont work until its logged in. This would be a great for full headless remote operation. Thx

on a related note, when is safe to update jetson nano 2gb without losing the gui?

cheers happy holidays.

Hi,

Do you mean autologin in terminal? It is not supported.

Hi pow,

Please use below steps to enable auto login:

1. Edit /etc/lightdm/lightdm.conf.d/50-nvidia.conf and add below two lines:
    autologin-user=nvidia 
    autologin-user-timeout=0
2. Save and reboot
1 Like

@carolyuu

are we supposed to use nvidia as login there or our user name.

Tried both and booted up only to the the login part

FYI Running headless through ttyl serial still requires login

but looks like ctrl-alt-f2 fixed the gui program and i am able auto login ang access via remote tunneling service,

thx

There is no way to enable autologin in tty console.

I tried this method nut it’s not working.
Any other suggestion please, I want to auto-login jetson nano 2gb ( Actually, I want to run a script automatically when the board is powered ).

Hi swapnilgtm1998,

Please help to open a new topic if it’s still an issue. Thanks