My password doesn't work after i enabled auto-login

Hey, i am using a jetson nano 2GB developer kit for my project.

I wanted the nano to log in automatically. However, after I made the settings as mentioned:

and restarted the nano, it still asked for my password. The real problem is that my usual password is no longer accepted even though it was not changed from my side. I also tried “nvidia” and “ubuntu” which are common default passwords but without success.

So i stuck in my login screen and have no access to my nano system.

Is there any possibility to solve this problem?

There are no defaults in recent years. This is only in fairly old releases. At some point California decided defaults were a bad idea and made a law regarding this, and thus first boot account setup was added rather than defaults.

Other people have enabled automatic login, and when done by the GUI, I have not heard of that failure. However, if you have a previously working login name/password, can you log in over ssh or serial console? If so, then you should be able to correct this. Also, if it is at the GUI login, then you could hit the CTRL-ALT-F2 key combination (or CTRL-ALT-F3 if F2 is in use) and get to a non-GUI login and try there.

Thanks for your reply. I noticed that my actually user account has been replaced by a new user with a different password. So i stuck in the GUI login as well as in the tth login after i pressed CTRL-ALT-F2.

I tried also to get access to Nano’s bios and change the password there but i read there is no such a bios in ARM processors as mentioned here:

So I think either i can fix it over the bootsloader or i must reinstall my Nano ubuntu distributionen

Even if there were a BIOS the BIOS has no access to an operating system password. A BIOS itself might have a password, but what you described was from a running operating system, not a BIOS stage (Jetsons don’t have a BIOS, but they have early boot stages somewhat similar).

If an account name is wrong, then of course the password will be wrong. My concern is that if this was a name/pass change due to malware (versus just setting up auto login wrong). If your Jetson is behind a router, then it is unlikely anyone ever got in. However, if the Jetson was exposed to uncontrolled traffic (such as on a shared router or a publicly routable IP address), then someone might have got in and changed this. Was the CTRL-ALT-F2 able to get to a login prompt? What about serial console (which is always king of access)?

I used it at home and the new account name is my firstname and my surname. Before the auto-login setup it was only my surname. Thats why i don’t think there was any malware i just wasn’t careful enough with the settings i guess. I have never used serial console before so i have to test it this week. But i watched a serial console video for jetson and i have also to enter the login password at the end, which is unfortunately unknown.

Looks like there is no possibility to create a new account or get access to my nano.

At least it should be possible to reinstall Nvidia ubuntu version or not? Seems to me the easiest way to solve my issue.

Did you set a password at first boot setup? If auto login is to the wrong name, then another terminal will still allow non-auto login and using another account name. You could try both first+surname, and also surname (provided you know the password). If you don’ t know the password, then you need to flash again (but you could clone first to save work, and possibly fix the password on the clone and use that to flash and get what you already have…but it is slow and uses lots of disk space).

Creating a new account requires login to an account and then using “sudo”, which in turn requires the password.

Yes, a simple flash is easiest. I’d recommend the most recent L4T/JetPack version (L4T is what gets flashed, each JetPack/SDK Manager release is tied to a specific L4T release). See:

I flashed it last night with SDK Manager. All i needed where already on github so i lost no data.

Thanks a lot for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.