Auto wake up using RTC not working

Hi, need to schedule my nano to shutdown and reboot after specific time. I wrote cron job to shutdown the system using rtc command. System shutdown on given time but it fails to reboot again. I tried the same cron job on TX2 and it works perfectly. I am not sure why it fails to boot nano. Could anyone help me to resolve the issue

May I know what command are you using? We only support wake from mem state and NOT off/disk state.

command im using is rtcwake -m off -s 25200

Is there a way to tweak h/w or s/w to enable off state??? Or is it limitation on nano board

Not tried further myself (I have no nano for checking), but considering that Nano disables low power mode, you would have to try to put nano in various power states (see -m option of rtcwake).
This may save less power, but might allow your system to resume.
Note that on hw side you would need big enough supercap for keeping rtc alive.
You may just try and let us know.

Yes, that is the limitation of nano.

We only support this one.

sudo rtcwake -m mem -s 60

Thanks Wayne for your response. Can this limitation be overcome by h/w or software tweak? Also, just to confirm the rtc command with mem mode will run on nano without any modification right?