Available Microsoft Visual Studio

Hello,

I had to use windows to program my Cuda program. I download the Cuda toolkit v8.0 and I notice on internet that Microsoft Visual Studio 2015 is not compatible .

What are the available version of Microsoft Studio to be able to use Cuda ?

You can use VS 2015 with CUDA 8. The compatible versions are listed in the windows install guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html#system-requirements

According to the Compatibility Matrix, CUDA 8.0.61 should be compatible with MSVS 2013. However, when compiling the sample projects in the Toolkit, I found many errors about d3dx9.h, d3dx10.h and d3dx11.h not being found.

Has anyone been able to successfully compile the CUDA 8 Toolkit sample projects in MSVS 2013?

Depending on your version of Microsoft windows and other factors, you may need to install various Microsoft SDK’s in order to compile these particular graphics samples. In particular the Microsoft DirectX SDK, or the Microsoft Windows SDK.

Thanks for the response. I will try it.

Thank you I finally try on my Visual Studio 2015 and it works.

The profiler seems to work properly too.

I have installed MS Windows SDK. However, the problem persists.

I have also tried to install MS DirectX SDK, but it seems that there is no version compatible for Windows 10.

Any suggestions? Thanks.

Today, I have tried with MSVS 2015, but the errors (about d3dx9.h, d3dx10.h and d3dx11.h not being found), still persist.

Okay, I must be stupid or something here. I can’t find any link to download VS2015.
I just made a PC so the latest version that I have access to is VS2017. While setting the IDE up, I selected for it to also install the VC++ 2015.3 v 140 toolset (which I figured would be the closest I could get), however when trying to run the CUDA setup installer, it still says that there’s no supported version of VS found. When it does install (I’ve tried this three times prior) everything goes off without a hitch except for the VS integration.
The end goal here is also to get running tensorflow, which I’ve been unsuccessful with thus far.
I’ve installed all of these things so easily on my Linux partition and am having a hard time believing that it should be this inaccessible on Windows.
Any help at all or pointers would be greatly appreciated.

Now that VS2017 is out, you have to work a little harder to find the VS2015 download. You can still get it here:

https://www.visualstudio.com/vs/older-downloads/

You will have to join their registered developer program if you’re not already a member, but its a free download after that.

I just downloaded VS2015 Update 2 installer from there a couple days ago.

Holy shit, I’ve searched through that site before and was certain at the time that they were keeping VS2015 behind a paywall. Thank you so much for letting me know that it was available. It worked on installing everything.

Do you remember how you did it? I cannot get the CUDA to integrate with VS2015. You also said, it was easy on Linux. Which linux version are you using?