Backend sample in tegra multimedia api error

I am trying to run backend sample which can be found in Tegra Api sample using jectpack3.1 and tx2.
When I try it with the provided video file (data/video/sample_outdoor_car_1080p_10fps.mp4), everything is OK. But when I use my own recorded video I get this error:
Segmentation fault (core dumped)

I recorded my own video using the VLC player in mp4 format.
I tried to convert the video file, but it did not work.
I am wondering if I should convert to a specific format? If so how can I do that?

Thanks.

Hi Payam, are you able to decode your h264 stream via tegra_multimedia_api/samples/00_video_decode/? And also the stream has to be 1920x1080.

Thanks for your reply.
I tried tegra_multimedia_api/samples/00_video_decode/
I get Segmentation fault (core dumped) error when I use my video captured by different tools.
When I record with tegra_multimedia_api/samples/10_camera_recording/ , video 00_video_decode works well.

I would like to record my video with my laptop.
Can I compile 10_camera_recording on my laptop?

Do you have other suggestion?

The input has to be 1920x1080 h264 stream. Seems like yours is an mp4? Please extract the h264 stream via http://yamb.unite-video.com/download.html

I tried it. Still, it is not working.
Also, I tried to convert a video captured by my cell phone, I got App run fail or Segmentation fault (core dumped) error

I ran this commnad:
./backend 1 ~/Videos/cell22.mp4 H264 --trt-deployfile …/…/data/Model/GoogleNet_one_class/GoogleNet_modified_oneClass_halfHD.prototxt --trt-modelfile …/…/data/Model/GoogleNet_one_class/GoogleNet_modified_oneClass_halfHD.caffemodel --trt-forcefp32 0 --trt-proc-interval 1 -fps 10

Hi Payam, the input has to be h264 stream. Looks like you input an mp4 file. A mp4 file is not h264 stream. Please understand the difference first.
Here is information https://www.winxdvd.com/answers/mp4-vs-h264.htm

Thanks!
I used H264 WebCam software for recording and it worked well. But still, I am not sure why http://yamb.unite-video.com/download.html is not working.