Error while running multimedia api sample!

Hello,
I just flashed Ubuntu 16.04 throughout Jetpack 3.0 and tried to run tegra multimedia API sample number 10 camera_recording, while the make process shows no error when I try to run it I always get:

Set governor to performance before enabling profiler
PRODUCER: Creating output stream
PRODUCER: Launching consumer thread
Failed to query video capabilities: Inappropriate ioctl for device
NvMMLiteOpen : Block : BlockType = 4 
===== MSENC =====
NvMMLiteBlockCreate : Block : BlockType = 4 
875967048
842091865
create vidoe encoder return true
CONSUMER: Waiting until producer is connected...
PRODUCER: Starting repeat capture requests.
CONSUMER: Producer has connected; continuing.
SCF: Error BadValue: not available (in src/services/gyro/SensorsManager.cpp, function initSensors(), line 278)
SCF: Error BadValue: not available (in src/services/gyro/SensorsManager.cpp, function initSensors(), line 278)
===== MSENC blits (mode: 1) into tiled surfaces =====
SCF: Error BadValue: not available (in src/services/gyro/SensorsManager.cpp, function initSensors(), line 278)
SCF: Error BadValue: not available (in src/services/gyro/SensorsManager.cpp, function initSensors(), line 278)
SCF: Error BadValue: motionMonitorThread failure (in src/services/gyro/MotionMonitorService.cpp, function motionMonitorThread(), line 343)
CONSUMER: Got EOS, exiting...
CONSUMER: Done.
PRODUCER: Done -- exiting.
************************************
Total Profiling Time = 0 sec
************************************

And cannot understand why!
Does anyone has any idea hot to successfully run this example?

Hi Adomi,
The print is harmless.

Please try to extend the CAPTURE_TIME like https://devtalk.nvidia.com/default/topic/1001197/jetson-tx2/error-in-src-services-gyro-sensorsmanager-cpp-initsensors-when-accessing-camera-on-tx2/post/5115524/#5115524

Thank you! That was exactly it also I had to change the type of the container for the output to mp4